summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-20 12:27:45 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-20 12:27:45 +0000
commitdcc7db556fef85d62b78144094efcd98fb388cad (patch)
tree8c1180ce6194fa006e80af19a410b5b173d590a6
parentAdded missing DEPENDs, see bug #144514. (diff)
downloadgentoo-2-dcc7db556fef85d62b78144094efcd98fb388cad.tar.gz
gentoo-2-dcc7db556fef85d62b78144094efcd98fb388cad.tar.bz2
gentoo-2-dcc7db556fef85d62b78144094efcd98fb388cad.zip
Version bump.
(Portage version: 2.1.1_pre5-r2)
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/coreutils-6.1.ebuild151
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-6.16
3 files changed, 163 insertions, 1 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index a0a66ceb2356..84950fead3bd 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.174 2006/07/06 19:19:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.175 2006/08/20 12:27:45 vapier Exp $
+
+*coreutils-6.1 (20 Aug 2006)
+
+ 20 Aug 2006; Mike Frysinger <vapier@gentoo.org> +coreutils-6.1.ebuild:
+ Version bump.
06 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> coreutils-5.96.ebuild,
coreutils-5.97.ebuild:
diff --git a/sys-apps/coreutils/coreutils-6.1.ebuild b/sys-apps/coreutils/coreutils-6.1.ebuild
new file mode 100644
index 000000000000..70a181281959
--- /dev/null
+++ b/sys-apps/coreutils/coreutils-6.1.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-6.1.ebuild,v 1.1 2006/08/20 12:27:45 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs autotools
+
+PATCH_VER="1.0"
+DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
+HOMEPAGE="http://www.gnu.org/software/coreutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-patches-${PATCH_VER}.tar.bz2
+ http://dev.gentoo.org/~kingtaco/mirror/${P}-patches-${PATCH_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+# give selinux guys a few days to catch up #144509
+#~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="acl nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ acl? ( kernel_linux? ( sys-apps/acl sys-apps/attr ) )
+ nls? ( >=sys-devel/gettext-0.15 )
+ >=sys-libs/ncurses-5.3-r5"
+DEPEND="${RDEPEND}
+ =sys-devel/automake-1.8*
+ >=sys-devel/autoconf-2.59d
+ >=sys-devel/m4-1.4-r1
+ sys-apps/help2man"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ # fixup expr for #123342
+ if [[ $(/bin/expr a : '\(a\)') != "a" ]] ; then
+ if [[ -x /bin/busybox ]] ; then
+ ln -sf /bin/busybox /bin/expr
+ else
+ eerror "Your expr binary appears to be broken, please fix it."
+ eerror "For more info, see http://bugs.gentoo.org/123342"
+ die "your expr is broke"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ PATCHDIR="${WORKDIR}/patch"
+
+ EPATCH_MULTI_MSG="Applying patches from Mandrake ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/mandrake
+
+ # Apply the ACL/SELINUX patches.
+ if use selinux ; then
+ EPATCH_MULTI_MSG="Applying SELINUX patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/selinux
+ ( cd "${PATCHDIR}" ; epatch selinux/GLUE* ) || die "glue failed"
+ elif use acl ; then
+ EPATCH_MULTI_MSG="Applying ACL patches ..." \
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/acl
+ fi
+
+ EPATCH_SUFFIX="patch" epatch "${PATCHDIR}"/generic
+ chmod a+rx tests/sort/sort-mb-tests
+
+ # Since we've patched many .c files, the make process will
+ # try to re-build the manpages by running `./bin --help`.
+ # When cross-compiling, we can't do that since 'bin' isn't
+ # a native binary, so let's just install outdated man-pages.
+ tc-is-cross-compiler && touch man/*.1
+ # There's no reason for this crap to use the private version
+ sed -i 's:__mempcpy:mempcpy:g' lib/*.c
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ if ! type -p cvs > /dev/null ; then
+ # Fix issues with gettext's autopoint if cvs is not installed,
+ # bug #28920.
+ export AUTOPOINT="/bin/true"
+ fi
+
+ local myconf=""
+ [[ ${USERLAND} == "GNU" ]] \
+ && myconf="${myconf} --bindir=/bin" \
+ || myconf="${myconf} --bindir=/usr/libexec/gnu"
+
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] \
+ && myconf="${myconf} --without-included-regex"
+
+ use static && append-ldflags -static
+ econf \
+ --enable-largefile \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ ${myconf} \
+ || die "econf"
+ emake || die "emake"
+}
+
+src_test() {
+ # Non-root tests will fail if the full path isnt
+ # accessible to non-root users
+ chmod -R go-w "${WORKDIR}"
+ chmod a+rx "${WORKDIR}"
+ addwrite /dev/full
+ export RUN_EXPENSIVE_TESTS="yes"
+ #export FETISH_GROUPS="portage wheel"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -f "${D}"/usr/lib/charset.alias
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS TODO
+
+ # remove files provided by other packages
+ rm "${D}"/bin/{kill,uptime} # procps
+ rm "${D}"/bin/{groups,su} # shadow
+ rm "${D}"/bin/hostname # net-tools
+ rm "${D}"/usr/share/man/man1/{groups,kill,hostname,su,uptime}.1
+ # provide by the man-pages package
+ rm "${D}"/usr/share/man/man1/{chgrp,chmod,chown,cp,dd,df,dir,dircolors}.1
+ rm "${D}"/usr/share/man/man1/{du,install,ln,ls,mkdir,mkfifo,mknod,mv}.1
+ rm "${D}"/usr/share/man/man1/{rm,rmdir,touch,vdir}.1
+
+ insinto /etc
+ newins src/dircolors.hin DIR_COLORS
+
+ if [[ ${USERLAND} == "GNU" ]] ; then
+ # move non-critical packages into /usr
+ cd "${D}"
+ dodir /usr/bin
+ mv bin/{csplit,expand,factor,fmt,fold,join,md5sum,nl,od} usr/bin
+ mv bin/{paste,pathchk,pinky,pr,printf,sha1sum,shred,sum,tac} usr/bin
+ mv bin/{tail,test,[,tsort,unexpand,users} usr/bin
+ cd bin
+ local x
+ for x in * ; do
+ dosym /bin/${x} /usr/bin/${x}
+ done
+ else
+ # For now, drop the man pages, collides with the ones of the system.
+ rm -rf ${D}/usr/share/man
+ fi
+}
diff --git a/sys-apps/coreutils/files/digest-coreutils-6.1 b/sys-apps/coreutils/files/digest-coreutils-6.1
new file mode 100644
index 000000000000..f03a5606c45d
--- /dev/null
+++ b/sys-apps/coreutils/files/digest-coreutils-6.1
@@ -0,0 +1,6 @@
+MD5 470cc109b06b94b77aa85499c146028d coreutils-6.1-patches-1.0.tar.bz2 45595
+RMD160 29bd2484c30defe897ecf4e710bb9fc8d41e7a0e coreutils-6.1-patches-1.0.tar.bz2 45595
+SHA256 12b8b13657f8a9278659b6cf393e649afe2d565ad086587b1c37953d5b0e1010 coreutils-6.1-patches-1.0.tar.bz2 45595
+MD5 fba00daaf5d301c78518fe353a78cd79 coreutils-6.1.tar.bz2 5290234
+RMD160 b59c5c43be629a42482107be05a3ed0b518b1b70 coreutils-6.1.tar.bz2 5290234
+SHA256 eed9783573718a818663aaf550c8c2ef2c298a5bb65c55ca15c1515bbf70e741 coreutils-6.1.tar.bz2 5290234