summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2006-11-26 13:39:50 +0000
committerHans de Graaff <graaff@gentoo.org>2006-11-26 13:39:50 +0000
commitdd57addded348ab08a00b26c905ba0c936b58a31 (patch)
tree329efed4cfe28d574cd1989c1e26af264cadbed8
parentHonour cflags, bug #156252 (diff)
downloadgentoo-2-dd57addded348ab08a00b26c905ba0c936b58a31.tar.gz
gentoo-2-dd57addded348ab08a00b26c905ba0c936b58a31.tar.bz2
gentoo-2-dd57addded348ab08a00b26c905ba0c936b58a31.zip
Modernize ebuild: use autotools, proper quoting, use emake, fix X dependencies.
(Portage version: 2.1.1-r2)
-rw-r--r--app-editors/xemacs/ChangeLog8
-rw-r--r--app-editors/xemacs/xemacs-21.4.19.ebuild29
2 files changed, 24 insertions, 13 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index c2afbccabc3b..94d0c235c2e2 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xemacs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.65 2006/09/04 03:40:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.66 2006/11/26 13:39:50 graaff Exp $
+
+ 26 Nov 2006; Hans de Graaff <graaff@gentoo.org> xemacs-21.4.19.ebuild:
+ Use autotools class to handle support for correct version of autoconf. Support
+ EXTRA_ECONF, fixing #145205. Use emake again as parallel builds have been
+ fixed upstream. Add x11-misc/xbitmaps to X dependencies. Quote variables that
+ may contain spaces.
04 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org>
-files/xemacs-21.4.8-ppc.diff, -files/xemacs-21.4.9-ppc.diff,
diff --git a/app-editors/xemacs/xemacs-21.4.19.ebuild b/app-editors/xemacs/xemacs-21.4.19.ebuild
index 768c46084918..5fd1b6c1ce99 100644
--- a/app-editors/xemacs/xemacs-21.4.19.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.19.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.19.ebuild,v 1.1 2006/06/21 04:11:15 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.19.ebuild,v 1.2 2006/11/26 13:39:50 graaff Exp $
-inherit eutils
+export WANT_AUTOCONF="2.1"
+inherit autotools eutils
DESCRIPTION="highly customizable open source text editor and application development system"
HOMEPAGE="http://www.xemacs.org/"
@@ -14,7 +15,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d berkdb"
-X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext"
+X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
DEPEND="virtual/libc
!virtual/xemacs
@@ -54,8 +55,14 @@ src_unpack() {
# see bug 58350
epatch ${FILESDIR}/${PN}-21.4.17-gdbm.patch
- autoconf-2.13
- use neXt && cp ${WORKDIR}/NeXT.XEmacs/xemacs-icons/* ${S}/etc/toolbar/
+
+ # Run autoconf. XEmacs tries to be smart by proivding a stub
+ # configure.ac file for autoconf 2.59 but this throws our
+ # autotools eclass so it must be removed first.
+ rm "${S}"/configure.ac
+ eautoconf
+
+ use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
}
src_compile() {
@@ -144,7 +151,7 @@ src_compile() {
use ppc64 && myconf="${myconf} --with-system-malloc"
- ./configure ${myconf} \
+ ./configure ${myconf} ${EXTRA_ECONF} \
--prefix=/usr \
--with-pop \
--with-ncurses \
@@ -154,15 +161,13 @@ src_compile() {
--with-site-modules=yes \
|| die
- # emake dont work on faster boxes it seems
- # azarah (04 Aug 2002)
- make || die
+ emake || die
}
src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man/man1 \
- infodir=${D}/usr/share/info \
+ make prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man/man1 \
+ infodir="${D}"/usr/share/info \
install gzip-el || die
# install base packages directories