summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:22:55 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:22:55 +0000
commitdd6ce2987682792ba173470b32196582d4d702b7 (patch)
treeaaad8f21e73254decab997a711689f5532de8356
parent[kde-base/step] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-dd6ce2987682792ba173470b32196582d4d702b7.tar.gz
gentoo-2-dd6ce2987682792ba173470b32196582d4d702b7.tar.bz2
gentoo-2-dd6ce2987682792ba173470b32196582d4d702b7.zip
[kde-base/ksplash] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.4.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 4fd0d8493432..c4d115819b10 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.54 2010/01/25 16:50:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.55 2010/02/09 00:22:55 alexxy Exp $
+
+*ksplash-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org> +ksplash-4.4.0.ebuild:
+ Version bump to KDE SC 4.4.0
*ksplash-4.3.5 (25 Jan 2010)
diff --git a/kde-base/ksplash/ksplash-4.4.0.ebuild b/kde-base/ksplash/ksplash-4.4.0.ebuild
new file mode 100644
index 000000000000..6b23a6dda5a7
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.4.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.4.0.ebuild,v 1.1 2010/02/09 00:22:55 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)
+ )
+
+ kde4-meta_src_configure
+}