summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-06-05 07:13:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-06-05 07:13:59 +0000
commite037a89ec50decf8f62f092bc4147fb41c758c54 (patch)
tree8df50b13803c66c729916e80e5d3741caa35a4aa
parentWe are still in the second quarter, as pointed out by fauli. (diff)
downloadgentoo-2-e037a89ec50decf8f62f092bc4147fb41c758c54.tar.gz
gentoo-2-e037a89ec50decf8f62f092bc4147fb41c758c54.tar.bz2
gentoo-2-e037a89ec50decf8f62f092bc4147fb41c758c54.zip
Fix build with gcc-4.4.0
(Portage version: 2.1.6.11/cvs/Linux x86_64)
-rw-r--r--games-emulation/snes9x/ChangeLog9
-rw-r--r--games-emulation/snes9x/files/snes9x-1.43-gcc440.patch16
-rw-r--r--games-emulation/snes9x/snes9x-1.43-r2.ebuild7
3 files changed, 26 insertions, 6 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 0b8a9af5bc1c..ed09d7b6a30d 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/snes9x
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.31 2008/02/09 06:22:47 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.32 2009/06/05 07:13:58 tupone Exp $
+
+ 05 Jun 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/snes9x-1.43-gcc440.patch, snes9x-1.43-r2.ebuild:
+ Fix build with gcc-4.4.0 and removed wrong --with-screenshot argument to
+ configure. All for version 1.43.
09 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org> snes9x-1.51.ebuild:
enhance license
diff --git a/games-emulation/snes9x/files/snes9x-1.43-gcc440.patch b/games-emulation/snes9x/files/snes9x-1.43-gcc440.patch
new file mode 100644
index 000000000000..b0905c3d8468
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.43-gcc440.patch
@@ -0,0 +1,16 @@
+--- unix/unix.cpp.old 2009-06-05 08:52:45.000000000 +0200
++++ unix/unix.cpp 2009-06-05 08:54:31.000000000 +0200
+@@ -1131,11 +1131,11 @@
+ {
+ *drive = 0;
+
+- char *slash = strrchr (path, '/');
++ const char *slash = strrchr (path, '/');
+ if (!slash)
+ slash = strrchr (path, '\\');
+
+- char *dot = strrchr (path, '.');
++ const char *dot = strrchr (path, '.');
+
+ if (dot && slash && dot < slash)
+ dot = NULL;
diff --git a/games-emulation/snes9x/snes9x-1.43-r2.ebuild b/games-emulation/snes9x/snes9x-1.43-r2.ebuild
index bec7ea89a6a0..5d6d1019b444 100644
--- a/games-emulation/snes9x/snes9x-1.43-r2.ebuild
+++ b/games-emulation/snes9x/snes9x-1.43-r2.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r2.ebuild,v 1.4 2007/10/09 14:40:41 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r2.ebuild,v 1.5 2009/06/05 07:13:58 tupone Exp $
# 3dfx support (glide) is disabled because it requires
# glide-v2 while we only provide glide-v3 in portage
# http://bugs.gentoo.org/show_bug.cgi?id=93097
-WANT_AUTOCONF=latest
inherit autotools eutils flag-o-matic multilib games
DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
@@ -47,6 +46,7 @@ src_unpack() {
"${FILESDIR}"/${P}-key-bindings-fix.patch \
"${FILESDIR}"/${P}-build.patch \
"${FILESDIR}"/${P}-gcc412.patch \
+ "${FILESDIR}"/${P}-gcc440.patch \
"${FILESDIR}"/${P}-config.patch
sed -i \
@@ -90,7 +90,6 @@ src_compile() {
$(use_with joystick) \
$(use_with debug debugger) \
$(use_with zlib) \
- --with-screenshot \
$(use_with dga extensions) \
|| die
# Makefile doesnt quite support parallel builds