summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-23 21:04:02 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-23 21:04:02 +0000
commite4948b05267b5ae62041cdbca95edfb3e0545653 (patch)
tree7ee6a759971cf1e9866bd5fe9e2ef97186545916
parentadded libtoolized gtk+ mask (diff)
downloadgentoo-2-e4948b05267b5ae62041cdbca95edfb3e0545653.tar.gz
gentoo-2-e4948b05267b5ae62041cdbca95edfb3e0545653.tar.bz2
gentoo-2-e4948b05267b5ae62041cdbca95edfb3e0545653.zip
new libtoolized version
-rw-r--r--x11-libs/gtk+/ChangeLog10
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.2-r51
-rw-r--r--x11-libs/gtk+/gtk+-2.0.2-r5.ebuild73
3 files changed, 83 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 63f94631abf9..a5747efc31db 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,9 +1,17 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.11 2002/05/22 19:51:12 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.12 2002/05/23 21:04:02 spider Exp $
+
+*gtk+-2.0.2-r5 (23 May 2002)
+ 23 May 2002; Spider <spider@gentoo.org> gtk+-2.0.2-r5.ebuild:
+ seems people who installed with the libtoolized version of gtk+ fails
+ when installing gtk+ again. Test this version if it works (read
+libtoolize)
+
*gtk+-2.0.2-r4 (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> gtk+-2.0.2-r4.ebuild:
+
lintool check
debug info back inside
remove libtoolize since it breaks things
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.2-r5 b/x11-libs/gtk+/files/digest-gtk+-2.0.2-r5
new file mode 100644
index 000000000000..665e7da38da8
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.2-r5
@@ -0,0 +1 @@
+MD5 b8df4c513323b9efc9a157703f25a07f gtk+-2.0.2.tar.bz2 5683089
diff --git a/x11-libs/gtk+/gtk+-2.0.2-r5.ebuild b/x11-libs/gtk+/gtk+-2.0.2-r5.ebuild
new file mode 100644
index 000000000000..e80df83c2f7d
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.2-r5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.2-r5.ebuild,v 1.1 2002/05/23 21:04:02 spider Exp $
+
+SLOT="2"
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.1
+ >=dev-libs/atk-1.0.1
+ >=x11-libs/pango-1.0.1
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+ # seems things broke here.. odd readding to test
+ libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use png || myconf="${myconf} --without-libpng"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-gdktarget=x11 \
+ ${myconf} \
+ --enable-debug || die
+# enable debug since glib fails if we disable it
+
+# gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+