summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 21:47:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 21:47:45 +0000
commitf945a90e7899b9ae378f32c8a6d8c50f9293a876 (patch)
tree3926a4a923a976225041d1fa572c3d6ebc7d778c
parentVersion bump for Gnome 3.12. (diff)
downloadgentoo-2-f945a90e7899b9ae378f32c8a6d8c50f9293a876.tar.gz
gentoo-2-f945a90e7899b9ae378f32c8a6d8c50f9293a876.tar.bz2
gentoo-2-f945a90e7899b9ae378f32c8a6d8c50f9293a876.zip
Version bump for Gnome 3.12.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-3.12.0.ebuild96
-rw-r--r--www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch39
3 files changed, 142 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index e950592fbc80..9b73d597f1a3 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.305 2014/04/27 09:10:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.306 2014/04/27 21:47:45 eva Exp $
+
+*epiphany-3.12.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +epiphany-3.12.0.ebuild,
+ +files/epiphany-3.12.0-missing-symbol.patch:
+ Version bump for Gnome 3.12.
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -epiphany-3.8.2.ebuild:
drop old
diff --git a/www-client/epiphany/epiphany-3.12.0.ebuild b/www-client/epiphany/epiphany-3.12.0.ebuild
new file mode 100644
index 000000000000..b9186771ee5b
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.12.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-3.12.0.ebuild,v 1.1 2014/04/27 21:47:45 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://projects.gnome.org/epiphany/"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.4:3[jit?]
+ >=net-libs/libsoup-2.42.1:2.4
+ >=x11-libs/gtk+-3.11.6:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# Tests refuse to run with the gsettings trick for some reason
+RESTRICT="test"
+
+src_prepare() {
+ # Fix missing symbol in webextensio.so
+ epatch "${FILESDIR}"/${P}-missing-symbol.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch b/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch
new file mode 100644
index 000000000000..6f2d8350ec23
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.12.0-missing-symbol.patch
@@ -0,0 +1,39 @@
+From 267ec3e2d7ca0f1881cb76d702ac673727f7507a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 22 Apr 2014 21:15:42 +0200
+Subject: [PATCH] Add missing files to webextension library
+
+Otherwise, results in:
+
+avril 22 21:09:36 kanae epiphany.desktop[32013]: Error loading module
+'/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so':
+/usr/lib64/epiphany/3.12/web-extensions/libephywebextension.so:
+undefined symbol: ephy_profile_utils_set_migration_version
+---
+ embed/web-extension/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/embed/web-extension/Makefile.am b/embed/web-extension/Makefile.am
+index 5bdb174..be4b08f 100644
+--- a/embed/web-extension/Makefile.am
++++ b/embed/web-extension/Makefile.am
+@@ -22,6 +22,8 @@ libephywebextension_la_SOURCES = \
+ $(top_srcdir)/lib/ephy-file-helpers.h \
+ $(top_srcdir)/lib/ephy-form-auth-data.c \
+ $(top_srcdir)/lib/ephy-form-auth-data.h \
++ $(top_srcdir)/lib/ephy-profile-utils.c \
++ $(top_srcdir)/lib/ephy-profile-utils.h \
+ $(top_srcdir)/lib/ephy-settings.c \
+ $(top_srcdir)/lib/ephy-settings.h \
+ $(top_srcdir)/lib/ephy-string.c \
+@@ -39,6 +41,7 @@ libephywebextension_la_CPPFLAGS = \
+ libephywebextension_la_CFLAGS = \
+ -DSHARE_DIR=\"$(pkgdatadir)\" \
+ -DTOP_SRC_DATADIR=\"$(top_srcdir)/data\" \
++ -DABS_TOP_BUILD_DIR=\"$(abs_top_builddir)\" \
+ $(WEB_EXTENSION_CFLAGS)
+
+ libephywebextension_la_LIBADD = \
+--
+1.9.0
+