summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-02-07 13:11:34 +0000
committerBen de Groot <yngwin@gentoo.org>2013-02-07 13:11:34 +0000
commitfb8c923936c8dabc09575ffea2122729d40d5ce3 (patch)
tree50d5c1a146a7157d14e7695c781f4f66494b3b98
parentStable for hppa, wrt bug #454906 (diff)
downloadgentoo-2-fb8c923936c8dabc09575ffea2122729d40d5ce3.tar.gz
gentoo-2-fb8c923936c8dabc09575ffea2122729d40d5ce3.tar.bz2
gentoo-2-fb8c923936c8dabc09575ffea2122729d40d5ce3.zip
remove old ~ ebuild
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--media-libs/mlt/ChangeLog5
-rw-r--r--media-libs/mlt/mlt-0.8.6.ebuild176
2 files changed, 4 insertions, 177 deletions
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index 7349307902ff..93da1be74574 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mlt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.102 2013/01/27 14:50:55 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.103 2013/02/07 13:11:34 yngwin Exp $
+
+ 07 Feb 2013; Ben de Groot <yngwin@gentoo.org> -mlt-0.8.6.ebuild:
+ remove old ~ ebuild
27 Jan 2013; Ben de Groot <yngwin@gentoo.org> mlt-0.8.8.ebuild:
enable gpl3, bug #453252
diff --git a/media-libs/mlt/mlt-0.8.6.ebuild b/media-libs/mlt/mlt-0.8.6.ebuild
deleted file mode 100644
index 86c3a70fb11d..000000000000
--- a/media-libs/mlt/mlt-0.8.6.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.8.6.ebuild,v 1.1 2012/11/21 00:48:52 aballier Exp $
-
-EAPI=4
-PYTHON_DEPEND="python? 2:2.6"
-inherit eutils toolchain-funcs multilib python
-
-DESCRIPTION="An open source multimedia framework, designed and developed for television broadcasting"
-HOMEPAGE="http://www.mltframework.org/"
-SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="compressed-lumas dv debug ffmpeg frei0r gtk jack kde libsamplerate melt
-mmx qt4 quicktime rtaudio sdl sse sse2 swfdec vorbis xine xml lua python ruby vdpau" # java perl php tcl
-IUSE="${IUSE} kernel_linux"
-
-#rtaudio will use OSS on non linux OSes
-RDEPEND="ffmpeg? ( virtual/ffmpeg[vdpau?] )
- dv? ( >=media-libs/libdv-0.104 )
- xml? ( >=dev-libs/libxml2-2.5 )
- vorbis? ( >=media-libs/libvorbis-1.1.2 )
- sdl? ( >=media-libs/libsdl-1.2.10[X,opengl]
- >=media-libs/sdl-image-1.2.4 )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
- jack? ( media-sound/jack-audio-connection-kit
- media-libs/ladspa-sdk
- >=dev-libs/libxml2-2.5 )
- frei0r? ( media-plugins/frei0r-plugins )
- gtk? ( x11-libs/gtk+:2
- media-libs/libexif
- x11-libs/pango )
- quicktime? ( media-libs/libquicktime )
- rtaudio? ( kernel_linux? ( media-libs/alsa-lib ) )
- swfdec? ( media-libs/swfdec )
- xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
- qt4? ( x11-libs/qt-gui:4 x11-libs/qt-svg:4 media-libs/libexif )
- !media-libs/mlt++
- lua? ( >=dev-lang/lua-5.1.4-r4 )
- ruby? ( dev-lang/ruby )"
-# sox? ( media-sound/sox )
-# java? ( >=virtual/jre-1.5 )
-# perl? ( dev-lang/perl )
-# php? ( dev-lang/php )
-# tcl? ( dev-lang/tcl )
-
-SWIG_DEPEND=">=dev-lang/swig-2.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- compressed-lumas? ( || ( media-gfx/imagemagick[png]
- media-gfx/graphicsmagick[imagemagick,png] ) )
- lua? ( ${SWIG_DEPEND} virtual/pkgconfig )
- python? ( ${SWIG_DEPEND} )
- ruby? ( ${SWIG_DEPEND} )"
-# java? ( ${SWIG_DEPEND} >=virtual/jdk-1.5 )
-# perl? ( ${SWIG_DEPEND} )
-# php? ( ${SWIG_DEPEND} )
-# tcl? ( ${SWIG_DEPEND} )
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.8.6-ruby-link.patch
-
- # respect CFLAGS LDFLAGS when building shared libraries. Bug #308873
- for x in python lua; do
- sed -i "/mlt.so/s: -lmlt++ :& ${CFLAGS} ${LDFLAGS} :" src/swig/$x/build || die
- done
- sed -i "/^LDFLAGS/s: += :& ${LDFLAGS} :" src/swig/ruby/build || die
-}
-
-src_configure() {
- tc-export CC CXX
-
- local myconf="--enable-gpl
- --enable-motion-est
- $(use_enable debug)
- $(use_enable dv)
- $(use_enable sse)
- $(use_enable sse2)
- $(use_enable swfdec)
- $(use_enable gtk gtk2)
- $(use_enable vorbis)
- $(use_enable sdl)
- $(use_enable jack jackrack)
- $(use_enable ffmpeg avformat)
- $(use_enable frei0r)
- $(use_enable melt)
- $(use_enable libsamplerate resample)
- $(use_enable rtaudio)
- $(use vdpau && echo ' --avformat-vdpau')
- $(use_enable xml)
- $(use_enable xine)
- $(use_enable kde kdenlive)
- $(use_enable qt4 qimage)
- --disable-sox"
- #$(use_enable sox) FIXME
-
- use ffmpeg && myconf="${myconf} --avformat-swscale"
-
- (use quicktime && use dv) || myconf="${myconf} --disable-kino"
-
- use compressed-lumas && myconf="${myconf} --luma-compress"
-
- ( use x86 || use amd64 ) && \
- myconf="${myconf} $(use_enable mmx)" ||
- myconf="${myconf} --disable-mmx"
-
- use melt || sed -i -e "s;src/melt;;" Makefile
-
- # TODO: add swig language bindings
- # see also http://www.mltframework.org/twiki/bin/view/MLT/ExtremeMakeover
-
- local swig_lang
- # TODO: java perl php tcl
- for i in lua python ruby ; do
- use $i && swig_lang="${swig_lang} $i"
- done
- [ -z "${swig_lang}" ] && swig_lang="none"
-
- econf ${myconf} --swig-languages="${swig_lang}"
- sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README docs/*.txt
-
- dodir /usr/share/${PN}
- insinto /usr/share/${PN}
- doins -r demo
-
- docinto swig
-
- # Install SWIG bindings
- if use lua; then
- cd "${S}"/src/swig/lua
- exeinto $(pkg-config --variable INSTALL_CMOD lua)
- doexe mlt.so || die
- dodoc play.lua
- fi
-
- if use python; then
- cd "${S}"/src/swig/python
- insinto $(python_get_sitedir)
- doins mlt.py || die
- exeinto $(python_get_sitedir)
- doexe _mlt.so || die
- dodoc play.py
- fi
-
- if use ruby; then
- cd "${S}"/src/swig/ruby
- exeinto $("${EPREFIX}"/usr/bin/ruby -r rbconfig -e 'print Config::CONFIG["sitearchdir"]')
- doexe mlt.so || die
- dodoc play.rb thumbs.rb
- fi
- # TODO: java perl php tcl
-}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize mlt.py
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup mlt.py
- fi
-}