summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-09 18:27:26 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-09 18:27:26 +0000
commitfc6fa3c38228bf46a5641cdb29256f33b7702270 (patch)
tree8f39250c3db3ea774c5dce152fc6e5328c1d1b1c
parent[bump] virtual/perl-Time-HiRes-1.972.300 (diff)
downloadgentoo-2-fc6fa3c38228bf46a5641cdb29256f33b7702270.tar.gz
gentoo-2-fc6fa3c38228bf46a5641cdb29256f33b7702270.tar.bz2
gentoo-2-fc6fa3c38228bf46a5641cdb29256f33b7702270.zip
Version bump. Remove useless elog messages. Merge dosbin/doins/dohtml commands and replace weird cp command.
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
-rw-r--r--net-analyzer/snmptt/ChangeLog10
-rw-r--r--net-analyzer/snmptt/snmptt-1.3.ebuild51
2 files changed, 59 insertions, 2 deletions
diff --git a/net-analyzer/snmptt/ChangeLog b/net-analyzer/snmptt/ChangeLog
index b521d35d5755..3f668638cd8f 100644
--- a/net-analyzer/snmptt/ChangeLog
+++ b/net-analyzer/snmptt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/snmptt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/ChangeLog,v 1.18 2008/03/28 18:27:37 hollow Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/ChangeLog,v 1.19 2011/06/09 18:27:26 jer Exp $
+
+*snmptt-1.3 (09 Jun 2011)
+
+ 09 Jun 2011; Jeroen Roovers <jer@gentoo.org> +snmptt-1.3.ebuild:
+ Version bump. Remove useless elog messages. Merge dosbin/doins/dohtml
+ commands and replace weird cp command.
28 Mar 2008; Benedikt Böhm <hollow@gentoo.org> snmptt-1.2.ebuild:
add ~amd64
diff --git a/net-analyzer/snmptt/snmptt-1.3.ebuild b/net-analyzer/snmptt/snmptt-1.3.ebuild
new file mode 100644
index 000000000000..8a3d295777de
--- /dev/null
+++ b/net-analyzer/snmptt/snmptt-1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/snmptt-1.3.ebuild,v 1.1 2011/06/09 18:27:26 jer Exp $
+
+EAPI="3"
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="SNMP Trap Translator"
+SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
+HOMEPAGE="http://www.snmptt.org/"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+IUSE="mysql postgres"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Config-IniFiles
+ net-analyzer/net-snmp
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+"
+
+src_prepare() {
+ # bug 105354, daemonize this thing
+ sed -i -e "s:mode = standalone:mode = daemon:g" snmptt.ini || die
+
+ echo "traphandle default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
+}
+
+src_install() {
+ into /usr
+ dosbin snmptt snmptthandler snmptt-net-snmp-test snmpttconvert \
+ snmpttconvertmib || die
+
+ insinto /etc/snmp
+ doins snmptt.ini examples/snmptt.conf.generic \
+ examples/snmptrapd.conf.sample || die
+ newins examples/snmptt.conf.generic snmptt.conf || die
+
+ dodoc BUGS ChangeLog README sample-trap
+ dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html \
+ docs/snmpttconvert.html docs/snmpttconvertmib.html || die
+
+ newinitd "${FILESDIR}"/snmptt.initd snmptt || die
+}