summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-11 14:17:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-11 14:17:00 +0000
commit3a69b32ca172a7c6f2748054feca9f3ecf1575f2 (patch)
tree28a78d2e0a21722844c414bcba5167e652f3c67f /app-accessibility/dasher
parentNew version for GNOME 2.24. Stability enhancements. (diff)
downloadgentoo-2-3a69b32ca172a7c6f2748054feca9f3ecf1575f2.tar.gz
gentoo-2-3a69b32ca172a7c6f2748054feca9f3ecf1575f2.tar.bz2
gentoo-2-3a69b32ca172a7c6f2748054feca9f3ecf1575f2.zip
New version for GNOME 2.24. Integration of gentoo patches and HIG work.
(Portage version: 2.2_rc11/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-accessibility/dasher')
-rw-r--r--app-accessibility/dasher/ChangeLog7
-rw-r--r--app-accessibility/dasher/dasher-4.9.0.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index b72fe2efa9d9..c324bed980c7 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.131 2008/09/25 16:03:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.132 2008/10/11 14:17:00 eva Exp $
+
+*dasher-4.9.0 (11 Oct 2008)
+
+ 11 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +dasher-4.9.0.ebuild:
+ New version for GNOME 2.24. Integration of gentoo patches and HIG work.
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> dasher-4.7.3.ebuild:
Stable for HPPA (bug #236971).
diff --git a/app-accessibility/dasher/dasher-4.9.0.ebuild b/app-accessibility/dasher/dasher-4.9.0.ebuild
new file mode 100644
index 000000000000..22b586c47d69
--- /dev/null
+++ b/app-accessibility/dasher/dasher-4.9.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.9.0.ebuild,v 1.1 2008/10/11 14:17:00 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
+HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="accessibility cairo gnome"
+
+# The package claims to support 'qte', but it hasn't been tested.
+# Any patches from someone who can test it are welcome.
+# <leonardop@gentoo.org>
+RDEPEND=">=dev-libs/glib-2.6
+ dev-libs/expat
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ gnome? (
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2 )
+ accessibility? (
+ app-accessibility/gnome-speech
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-extra/at-spi-1
+ dev-libs/atk )
+ cairo? ( >=x11-libs/gtk+-2.8 )
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome? (
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/scrollkeeper )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ # we might want to support japanese and chinese input at some point
+ # --enable-japanese
+ # --enable-chinese
+ # --enable-tilt (tilt sensor support)
+
+ G2CONF="--disable-scrollkeeper
+ $(use_enable accessibility a11y)
+ $(use_enable accessibility speech)
+ $(use_with cairo)
+ $(use_with gnome)"
+}