summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-02-12 08:02:32 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-02-12 08:02:32 +0000
commit8a7093b9d2d9cb34066895a30773779c022edaa8 (patch)
treeef47d5e1e53963bf5e193ab49d8a4448c05336b9 /app-accessibility/dasher
parentforce make -j1 for radiusclient (#81544) (diff)
downloadgentoo-2-8a7093b9d2d9cb34066895a30773779c022edaa8.tar.gz
gentoo-2-8a7093b9d2d9cb34066895a30773779c022edaa8.tar.bz2
gentoo-2-8a7093b9d2d9cb34066895a30773779c022edaa8.zip
Patch to fix a broken test in the configure script. See bug #79181.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-accessibility/dasher')
-rw-r--r--app-accessibility/dasher/ChangeLog7
-rw-r--r--app-accessibility/dasher/dasher-3.2.11.ebuild12
-rw-r--r--app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch25
3 files changed, 41 insertions, 3 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index b5542235ad34..293ff0259ed9 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.26 2005/01/17 20:15:13 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.27 2005/02/12 08:02:32 leonardop Exp $
+
+ 12 Feb 2004; Leonardo Boshell <leonardop@gentoo.org> dasher-3.2.11.ebuild,
+ files/dasher-3.2.11-xtst_fix.patch:
+ Added patch to fix a broken library test that can break compilation.
+ Thanks to <s.b.wielinga> for his contribution on bug #79181.
17 Jan 2005; Simon Stelling <blubb@gentoo.org> dasher-3.2.11.ebuild:
stable on amd64
diff --git a/app-accessibility/dasher/dasher-3.2.11.ebuild b/app-accessibility/dasher/dasher-3.2.11.ebuild
index 1285b5eb58af..91dee56d3566 100644
--- a/app-accessibility/dasher/dasher-3.2.11.ebuild
+++ b/app-accessibility/dasher/dasher-3.2.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-3.2.11.ebuild,v 1.8 2005/01/17 20:15:13 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-3.2.11.ebuild,v 1.9 2005/02/12 08:02:32 leonardop Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
@@ -38,3 +38,11 @@ G2CONF="${G2CONF} $(use_with gnome) $(use_with accessibility a11y) \
$(use_with accessibility speech)"
DOCS="ABOUT-NLS AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix test phase for the xtst library
+ epatch ${FILESDIR}/${P}-xtst_fix.patch
+}
diff --git a/app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch b/app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch
new file mode 100644
index 000000000000..5ea12bfc2882
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch
@@ -0,0 +1,25 @@
+diff -ur dasher-3.2.11.orig/configure dasher-3.2.11/configure
+--- dasher-3.2.11.orig/configure 2004-08-02 23:56:24.000000000 +0200
++++ dasher-3.2.11/configure 2005-01-23 09:53:07.000000000 +0100
+@@ -11258,18 +11300,18 @@
+ rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ done
+- if test "x$XTST_LIBS" = x; then
+- { { echo "$as_me:$LINENO: error: Couldn't find the Xtst library. Check config.log for details" >&5
++ fi
++ if test "x$XTST_LIBS" = x; then
++ { { echo "$as_me:$LINENO: error: Couldn't find the Xtst library. Check config.log for details" >&5
+ echo "$as_me: error: Couldn't find the Xtst library. Check config.log for details" >&2;}
+ { (exit 1); exit 1; }; }
+- else
+- X_LIBS="$X_LIBS $XTST_LIBS"
++ else
++ X_LIBS="$X_LIBS $XTST_LIBS"
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_XTST 1
+ _ACEOF
+
+- fi
+ fi