summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2007-01-31 06:00:27 +0000
committerWilliam Hubbs <williamh@gentoo.org>2007-01-31 06:00:27 +0000
commit585a11b88ead32fc7996ef4caf6cb2f700cab2b0 (patch)
tree8c73bb91bbbe7eceea3c3a78c2fbcc6acec437c2 /app-accessibility/espeak/espeak-1.19.ebuild
parentMarked ppc stable. (diff)
downloadgentoo-2-585a11b88ead32fc7996ef4caf6cb2f700cab2b0.tar.gz
gentoo-2-585a11b88ead32fc7996ef4caf6cb2f700cab2b0.tar.bz2
gentoo-2-585a11b88ead32fc7996ef4caf6cb2f700cab2b0.zip
Version bump.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'app-accessibility/espeak/espeak-1.19.ebuild')
-rw-r--r--app-accessibility/espeak/espeak-1.19.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-accessibility/espeak/espeak-1.19.ebuild b/app-accessibility/espeak/espeak-1.19.ebuild
new file mode 100644
index 000000000000..04f6a961efb5
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.19.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.19.ebuild,v 1.1 2007/01/31 06:00:27 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/portaudio-18.1-r5
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+}
+
+src_compile() {
+ cd src
+ emake CXXFLAGS="${CXXFLAGS}" || die "Compilation failed"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ cd "${S}"
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}