summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2012-12-04 04:50:43 +0000
committerJesus Rivero <neurogeek@gentoo.org>2012-12-04 04:50:43 +0000
commitec0ac8e6ac67a0ab5399dd961f3760b606fe392d (patch)
tree353f6af72194f3a51eb690b0c0c02640e2d9e381 /app-accessibility
parentUpstream recommended to me that we install the kmod binary in /bin. Also I ha... (diff)
downloadgentoo-2-ec0ac8e6ac67a0ab5399dd961f3760b606fe392d.tar.gz
gentoo-2-ec0ac8e6ac67a0ab5399dd961f3760b606fe392d.tar.bz2
gentoo-2-ec0ac8e6ac67a0ab5399dd961f3760b606fe392d.zip
Revbump. Makes it compile with gcc-4.7
(Portage version: 2.2.0_alpha138/cvs/Linux i686, signed Manifest commit with key 748B2C601F6F0683)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/festival/ChangeLog8
-rw-r--r--app-accessibility/festival/festival-2.1-r1.ebuild125
-rw-r--r--app-accessibility/festival/files/festival-2.1-gcc4.7.patch29
3 files changed, 161 insertions, 1 deletions
diff --git a/app-accessibility/festival/ChangeLog b/app-accessibility/festival/ChangeLog
index ca171a31f260..0c4d4592914a 100644
--- a/app-accessibility/festival/ChangeLog
+++ b/app-accessibility/festival/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/festival
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.106 2012/09/20 19:58:15 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.107 2012/12/04 04:50:43 neurogeek Exp $
+
+*festival-2.1-r1 (03 Dec 2012)
+
+ 03 Dec 2012; Jesus Rivero <neurogeek@gentoo.org> +festival-2.1-r1.ebuild,
+ +files/festival-2.1-gcc4.7.patch:
+ Revbump. Makes it compile with gcc-4.7
20 Sep 2012; Jesus Rivero <neurogeek@gentoo.org>
-festival-1.96_beta-r1.ebuild, -festival-2.0.95_beta.ebuild,
diff --git a/app-accessibility/festival/festival-2.1-r1.ebuild b/app-accessibility/festival/festival-2.1-r1.ebuild
new file mode 100644
index 000000000000..491975aee1e2
--- /dev/null
+++ b/app-accessibility/festival/festival-2.1-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-2.1-r1.ebuild,v 1.1 2012/12/04 04:50:43 neurogeek Exp $
+
+EAPI="2"
+inherit eutils multilib toolchain-funcs user
+
+MY_PV="${PV}-release"
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/festival/"
+SITE="http://www.festvox.org/packed/${PN}/${PV}"
+SRC_URI="${SITE}/${MY_P}.tar.gz
+ ${SITE}/festlex_CMU.tar.gz
+ ${SITE}/festlex_OALD.tar.gz
+ ${SITE}/festlex_POSLEX.tar.gz
+ ${SITE}/festvox_cmu_us_awb_cg.tar.gz
+ ${SITE}/festvox_cmu_us_rms_cg.tar.gz
+ ${SITE}/festvox_cmu_us_slt_arctic_hts.tar.gz
+ ${SITE}/festvox_rablpc16k.tar.gz
+ ${SITE}/festvox_kallpc16k.tar.gz
+ ${SITE}/speech_tools-${MY_PV}.tar.gz"
+
+LICENSE="FESTIVAL BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~app-accessibility/speech-tools-2.1
+ >=sys-libs/ncurses-5.6-r2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/festival
+
+pkg_setup() {
+ enewuser festival -1 -1 -1 audio
+}
+
+src_prepare() {
+ # tell festival to use the speech-tools we have installed.
+ sed -i -e "s:\(EST=\).*:\1${EPREFIX}/usr/share/speech-tools:" "${S}"/config/config.in
+ sed -i -e "s:\$(EST)/lib:/usr/$(get_libdir):" "${S}"/config/project.mak
+
+ # fix the reference to /usr/lib/festival
+ sed -i -e "s:\(FTLIBDIR.*=.*\)\$.*:\1${EPREFIX}/usr/share/festival:" "${S}"/config/project.mak
+
+ # Fix path for examples in festival.scm
+ sed -i -e "s:\.\./examples/:${EPREFIX}/usr/share/doc/${PF}/examples/:" "${S}"/lib/festival.scm
+
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+ epatch "${FILESDIR}/${P}-init-scm.patch"
+ epatch "${FILESDIR}/${P}-gentoo-system.patch"
+
+ # copy what we need for MultiSyn from speech_tools.
+ cp -pr "${WORKDIR}"/speech_tools/base_class "${S}"/src/modules/MultiSyn
+
+ epatch "${FILESDIR}/${P}-gcc4.7.patch"
+
+ echo "(Parameter.set 'Audio_Command \"aplay -q -c 1 -t raw -f s16 -r \$SR \$FILE\")" >> "${S}"/lib/siteinit.scm
+ echo "(Parameter.set 'Audio_Method 'Audio_Command)" >> "${S}"/lib/siteinit.scm
+}
+
+src_configure() {
+ econf || die "econf failed"
+}
+
+src_compile() {
+ emake -j1 PROJECT_LIBDEPS="" REQUIRED_LIBDEPS="" LOCAL_LIBDEPS="" \
+ OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ # Install the binaries
+ dobin src/main/festival
+ dobin lib/etc/*Linux*/audsp
+ dolib.a src/lib/libFestival.a
+
+ # Install the main libraries
+ insinto /usr/share/festival
+ doins -r lib/*
+
+ # Install the examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # Need to fix saytime, etc. to look for festival in the correct spot
+ for ex in "${D}"/usr/share/doc/${PF}/examples/*.sh; do
+ exnoext=${ex%%.sh}
+ chmod a+x "${exnoext}"
+ dosed "s:${S}/bin/festival:/usr/bin/festival:" "${exnoext##$D}"
+ done
+
+ # Install the header files
+ insinto /usr/include/festival
+ doins src/include/*.h
+
+ insinto /etc/festival
+ doins lib/site*
+
+ # Install the docs
+ dodoc "${S}"/{ACKNOWLEDGMENTS,NEWS,README}
+ doman "${S}"/doc/{festival.1,festival_client.1}
+
+ # create the directory where our log file will go.
+ diropts -m 0755 -o festival -g audio
+ keepdir /var/log/festival
+
+}
+
+pkg_postinst() {
+ elog
+ elog " Useful examples include saytime, text2wave. For example, try:"
+ elog " \"/usr/share/doc/${PF}/examples/saytime\""
+ elog
+ elog " Or for something more fun:"
+ elog ' "echo "Gentoo can speak" | festival --tts"'
+ elog
+ elog "This version also allows configuration of site specific"
+ elog "initialization in /etc/festival/siteinit.scm and"
+ elog "variables in /etc/festival/sitevars.scm."
+ elog
+}
diff --git a/app-accessibility/festival/files/festival-2.1-gcc4.7.patch b/app-accessibility/festival/files/festival-2.1-gcc4.7.patch
new file mode 100644
index 000000000000..8ebc8cc472c0
--- /dev/null
+++ b/app-accessibility/festival/files/festival-2.1-gcc4.7.patch
@@ -0,0 +1,29 @@
+diff -uNr festival.orig/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc festival/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc
+--- festival.orig/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc 2012-12-02 23:03:27.000000000 +0000
++++ festival/src/modules/MultiSyn/base_class/EST_TSimpleVector.cc 2012-12-02 23:21:17.000000000 +0000
+@@ -42,6 +42,7 @@
+
+ #include "EST_TSimpleVector.h"
+ #include "EST_matrix_support.h"
++#include <cstring>
+ #include <fstream>
+ #include "EST_cutils.h"
+
+@@ -49,7 +50,7 @@
+ {
+ if (this->p_column_step==1 && a.p_column_step==1)
+ {
+- resize(a.n(), FALSE);
++ this->resize(a.n(), FALSE);
+ memcpy((void *)(this->p_memory), (const void *)(a.p_memory), this->n() * sizeof(T));
+ }
+ else
+@@ -70,7 +71,7 @@
+ int old_offset = this->p_offset;
+ unsigned int q;
+
+- just_resize(newn, &old_vals);
++ this->just_resize(newn, &old_vals);
+
+ if (set && old_vals)
+ {