summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-04-08 13:06:51 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-04-08 13:06:51 +0000
commitbca28b0541556d6f940f97d6f5d7f99cf751cd8b (patch)
tree7522c2adb0ce67769ece6db4671f46c4bd1cf86b /app-admin/authbind
parentRemove old. (diff)
downloadgentoo-2-bca28b0541556d6f940f97d6f5d7f99cf751cd8b.tar.gz
gentoo-2-bca28b0541556d6f940f97d6f5d7f99cf751cd8b.tar.bz2
gentoo-2-bca28b0541556d6f940f97d6f5d7f99cf751cd8b.zip
Initial commit for bug #74301, ebuild written by me.
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'app-admin/authbind')
-rw-r--r--app-admin/authbind/ChangeLog9
-rw-r--r--app-admin/authbind/authbind-2.1.1.ebuild52
-rw-r--r--app-admin/authbind/files/authbind-2.1.1-respect-flags.patch26
-rw-r--r--app-admin/authbind/metadata.xml8
4 files changed, 95 insertions, 0 deletions
diff --git a/app-admin/authbind/ChangeLog b/app-admin/authbind/ChangeLog
new file mode 100644
index 000000000000..78e7fd4e9690
--- /dev/null
+++ b/app-admin/authbind/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-admin/authbind
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/authbind/ChangeLog,v 1.1 2013/04/08 13:06:51 dev-zero Exp $
+
+*authbind-2.1.1 (08 Apr 2013)
+
+ 08 Apr 2013; Tiziano Müller <dev-zero@gentoo.org> +authbind-2.1.1.ebuild,
+ +files/authbind-2.1.1-respect-flags.patch, +metadata.xml:
+ Initial commit for bug #74301, ebuild written by me.
diff --git a/app-admin/authbind/authbind-2.1.1.ebuild b/app-admin/authbind/authbind-2.1.1.ebuild
new file mode 100644
index 000000000000..78375fa65df4
--- /dev/null
+++ b/app-admin/authbind/authbind-2.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/authbind/authbind-2.1.1.ebuild,v 1.1 2013/04/08 13:06:51 dev-zero Exp $
+
+EAPI=5
+
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Bind sockets to privileged ports without root"
+HOMEPAGE="http://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-respect-flags.patch"
+}
+
+src_configure() {
+ sed -i \
+ -e "s|^prefix=.*|prefix=/usr|" \
+ -e "s|^lib_dir=.*|lib_dir=\$(prefix)/$(get_libdir)|" \
+ -e "s|^libexec_dir=.*|libexec_dir=\$(prefix)/libexec/authbind|" \
+ -e "s|^SHARED_LDFLAGS=.*|SHARED_LDFLAGS=$(raw-ldflags)|" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e 's|/usr/lib|/usr/libexec|' \
+ authbind-helper.8 || die "sed failed"
+}
+
+src_install() {
+ dobin authbind
+ doman authbind.1 authbind-helper.8
+
+ ln -s libauthbind.so.* libauthbind.so.$(awk -F= '/MAJOR=/ { print $2 }' < Makefile)
+ dolib.so libauthbind.so*
+
+ exeinto /usr/libexec/authbind
+ exeopts -m4755
+ doexe helper
+
+ keepdir /etc/authbind/by{addr,port,uid}
+
+ dodoc debian/changelog
+}
diff --git a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
new file mode 100644
index 000000000000..2a9eb5f6b84c
--- /dev/null
+++ b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index c1eed73..932ea60 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s
+ INSTALL_DIR ?= install -o root -g root -m 755 -d
+ STRIP ?= strip
+
+-OPTIMISE= -O2
+-LDFLAGS= -g
+ LIBS= -ldl -lc
+-CFLAGS= -g $(OPTIMISE) \
++SHARED_LDFLAGS=
++CFLAGS+= \
+ -Wall -Wwrite-strings -Wpointer-arith -Wimplicit \
+ -Wnested-externs -Wmissing-prototypes -Wstrict-prototypes
+ CPPFLAGS= -DMAJOR_VER='"$(MAJOR)"' -DMINOR_VER='"$(MINOR)"' \
+@@ -82,7 +81,7 @@ helper: helper.o
+ helper.o authbind.o: authbind.h
+
+ $(LIBTARGET): libauthbind.o
+- ld -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
++ $(LD) $(SHARED_LDFLAGS) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+
+ clean distclean:
+ rm -f $(TARGETS) *.o *~ ./#*# *.bak *.new core
diff --git a/app-admin/authbind/metadata.xml b/app-admin/authbind/metadata.xml
new file mode 100644
index 000000000000..5b2a5c55470b
--- /dev/null
+++ b/app-admin/authbind/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>