summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-01-30 00:19:10 +0000
committerDonny Davies <woodchip@gentoo.org>2003-01-30 00:19:10 +0000
commitd74b653998de0ed4e6714d5ccd33910f343aef46 (patch)
treec18674b2dc9ac6422fff240c6152dbbc69795d6c /app-admin/bacula
parentRev bump making changes as suggested on bug #8780 (diff)
downloadgentoo-2-d74b653998de0ed4e6714d5ccd33910f343aef46.tar.gz
gentoo-2-d74b653998de0ed4e6714d5ccd33910f343aef46.tar.bz2
gentoo-2-d74b653998de0ed4e6714d5ccd33910f343aef46.zip
new package; created my me
Diffstat (limited to 'app-admin/bacula')
-rw-r--r--app-admin/bacula/ChangeLog8
-rw-r--r--app-admin/bacula/bacula-1.29.ebuild96
-rw-r--r--app-admin/bacula/files/bacula-init56
-rw-r--r--app-admin/bacula/files/digest-bacula-1.291
4 files changed, 161 insertions, 0 deletions
diff --git a/app-admin/bacula/ChangeLog b/app-admin/bacula/ChangeLog
new file mode 100644
index 000000000000..fa379f3a2b1e
--- /dev/null
+++ b/app-admin/bacula/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-admin/bacula
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.1 2003/01/30 00:19:10 woodchip Exp $
+
+*bacula-1.29 (29 Jan 2003)
+
+ 29 Jan 2003; Donny Davies <woodchip@gentoo.org> :
+ Initial import of Bacula; initscript and ebuild written by me.
diff --git a/app-admin/bacula/bacula-1.29.ebuild b/app-admin/bacula/bacula-1.29.ebuild
new file mode 100644
index 000000000000..3f9e4986675e
--- /dev/null
+++ b/app-admin/bacula/bacula-1.29.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/bacula-1.29.ebuild,v 1.1 2003/01/30 00:19:10 woodchip Exp $
+
+DESCRIPTION="Bacula is a featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+#theres a local sqlite use flag. use it -OR- mysql, not both.
+#mysql is the reccomended choice ...
+DEPEND=">=sys-libs/zlib-1.1.4
+ readline? >=sys-libs/readline-4.3
+ tcpd? >=sys-apps/tcp-wrappers-7.6
+ ssl? >=dev-libs/openssl-0.9.6
+ gnome? gnome-base/gnome-libs
+ mysql? >=dev-db/mysql-3.23
+ sqlite? >=dev-db/sqlite-2.7
+ X? virtual/x11"
+RDEPEND="${DEPEND} sys-apps/mtx app-arch/mt-st"
+IUSE="readline tcpd ssl gnome mysql sqlite X"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+src_compile() {
+ local myconf
+
+ #define this var to something to skip building the other daemons ...
+ [ -n "$BUILD_CLIENT_ONLY" ] && myconf="${myconf} --enable-client-only"
+
+ #might be handy to have static bins in certain situations ...
+ use static && myconf="${myconf} --enable-static-tools \
+ --enable-static-fd --enable-static-sd \
+ --enable-static-dir --enable-static-cons"
+
+ use readline && myconf="${myconf} --enable-readline" || myconf="${myconf} --disable-readline"
+
+ use gnome && myconf="${myconf} --enable-gnome" || myconf="${myconf} --disable-gnome"
+
+ use tcpd && myconf="${myconf} --enable-tcpd" || myconf="${myconf} --disable-tcpd"
+
+ use mysql && myconf="${myconf} --with-mysql" || myconf="${myconf} --without-mysql"
+
+ use sqlite && myconf="${myconf} --with-sqlite" || myconf="${myconf} --without-sqlite"
+
+ use X && myconf="${myconf} --with-x" || myconf="${myconf} --without-x"
+
+#not ./configure'able
+# use ssl && myconf="${myconf} --enable-ssl" || myconf="${myconf} --disable-ssl"
+
+ #mysql is the reccomended choice ...
+ if use mysql && use sqlite
+ then
+ #supposed to have only one or the either, nuke '--with-sqlite'
+ myconf=${myconf/--with-sqlite/}
+ fi
+
+ einfo "myconf is: $myconf"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lib/bacula \
+ --with-working-dir=/var/lib/bacula \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ rm -rf ${D}/var #empty dir
+
+ dodoc ABOUT-NLS COPYING ChangeLog CheckList INSTALL \
+ README ReleaseNotes kernstodo doc/bacula.pdf
+ cp -a examples ${D}/usr/share/doc/${PF}
+ chown -R root.root ${D}/usr/share/doc/${PF} #hrmph :\
+ dohtml -r doc/html-manual doc/home-page
+}
+
+pkg_postinst() {
+ # empty dir ...
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/bacula
+ einfo
+ einfo "If this is a new install and you plan to use mysql for your"
+ einfo "catalog database, then you should now create it by doing"
+ einfo "these two commands:"
+ einfo " sh /etc/bacula/create_mysql_database"
+ einfo " sh /etc/bacula/make_mysql_tables"
+ einfo "Then setup your configuration files in /etc/bacula and"
+ einfo "start the daemons:"
+ einfo " /etc/init.d/bacula start"
+ einfo
+}
diff --git a/app-admin/bacula/files/bacula-init b/app-admin/bacula/files/bacula-init
new file mode 100644
index 000000000000..ab0481a5f2ce
--- /dev/null
+++ b/app-admin/bacula/files/bacula-init
@@ -0,0 +1,56 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/files/bacula-init,v 1.1 2003/01/30 00:19:10 woodchip Exp $
+
+depend() {
+ need net
+ use mysql
+}
+
+opts="test"
+
+# A client would only need to run the file daemon, so if thats the
+# case for this machine just comment the other two out below here...
+start() {
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd
+ result=$?
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd
+ result=$(( $result + $? ))
+ sleep 2
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir
+ result=$(( $result + $? ))
+ eend $result
+}
+
+# The default port numbers appear in the pidfile paths below.
+# Might wanna programmatically grab them from the config files
+# or something...
+stop() {
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.9102.pid
+ result=$?
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.9103.pid
+ result=$(( $result + $? ))
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.9101.pid
+ result=$(( $result + $? ))
+ eend $result
+}
+
+test() {
+ ebegin "Testing bacula storage daemon configuration"
+ /usr/sbin/bacula-sd -t
+ result=$?
+ ebegin "Testing bacula file daemon configuration"
+ /usr/sbin/bacula-fd -t
+ result=$(( $result + $? ))
+ ebegin "Testing bacula director configuration"
+ /usr/sbin/bacula-dir -t
+ result=$(( $result + $? ))
+ eend $result
+}
diff --git a/app-admin/bacula/files/digest-bacula-1.29 b/app-admin/bacula/files/digest-bacula-1.29
new file mode 100644
index 000000000000..e652aaed5c5c
--- /dev/null
+++ b/app-admin/bacula/files/digest-bacula-1.29
@@ -0,0 +1 @@
+MD5 32ea08056be1a241534841f7a98e7895 bacula-1.29.tar.gz 2707645