summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-14 05:27:40 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-14 05:27:40 +0000
commit857165ede4077c7ccb88dc6af72eb38403f86b80 (patch)
tree935bd45af2604d3d808727d384ef89a2b93acf5f /app-admin/cancd
parentTouchup style. (diff)
downloadgentoo-2-857165ede4077c7ccb88dc6af72eb38403f86b80.tar.gz
gentoo-2-857165ede4077c7ccb88dc6af72eb38403f86b80.tar.bz2
gentoo-2-857165ede4077c7ccb88dc6af72eb38403f86b80.zip
Fix building with newer glibc #246734 by Diego E. Pettenò.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-admin/cancd')
-rw-r--r--app-admin/cancd/ChangeLog8
-rw-r--r--app-admin/cancd/cancd-0.1.0-r1.ebuild25
-rw-r--r--app-admin/cancd/files/cancd-0.1.0-build.patch14
3 files changed, 33 insertions, 14 deletions
diff --git a/app-admin/cancd/ChangeLog b/app-admin/cancd/ChangeLog
index 6a4f0d45ae3d..bcfbf78bc547 100644
--- a/app-admin/cancd/ChangeLog
+++ b/app-admin/cancd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/cancd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/ChangeLog,v 1.6 2008/11/14 15:00:41 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/ChangeLog,v 1.7 2009/01/14 05:27:34 vapier Exp $
+
+ 14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/cancd-0.1.0-build.patch, cancd-0.1.0-r1.ebuild:
+ Fix building with newer glibc #246734 by Diego E. Pettenò.
14 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
cancd-0.1.0-r1.ebuild:
diff --git a/app-admin/cancd/cancd-0.1.0-r1.ebuild b/app-admin/cancd/cancd-0.1.0-r1.ebuild
index b4320c83ade2..72a5f8cb46e9 100644
--- a/app-admin/cancd/cancd-0.1.0-r1.ebuild
+++ b/app-admin/cancd/cancd-0.1.0-r1.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/cancd-0.1.0-r1.ebuild,v 1.4 2008/11/14 15:00:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cancd/cancd-0.1.0-r1.ebuild,v 1.5 2009/01/14 05:27:34 vapier Exp $
inherit eutils
-DESCRIPTION="This is the CA NetConsole Daemon, a daemon to receive output from
-the Linux netconsole driver."
+DESCRIPTION="the CA NetConsole Daemon, a daemon to receive output from the Linux netconsole driver"
HOMEPAGE="http://oss.oracle.com/projects/cancd/"
SRC_URI="http://oss.oracle.com/projects/cancd/dist/files/source/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -15,13 +15,15 @@ IUSE=""
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-c-cleanup.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch #246734
+ epatch "${FILESDIR}"/${P}-c-cleanup.patch
# slight makefile cleanup
- sed -i.orig \
+ sed -i \
-e '/^CFLAGS/s,-g,,' \
-e '/^CFLAGS/s,-O2,-Wall -W -Wextra -Wundef -Wendif-labels -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Wsign-compare -Waggregate-return -Wstrict-prototypes -Wredundant-decls -Wunreachable-code -Wlong-long,' \
-e '/rm cancd cancd.o/s,rm,rm -f,' \
- ${S}/Makefile
+ Makefile || die
}
src_compile() {
@@ -29,12 +31,11 @@ src_compile() {
}
src_install() {
- into /usr
dosbin cancd || die "dosbin failed"
- newinitd ${FILESDIR}/cancd-init.d cancd
- newconfd ${FILESDIR}/cancd-conf.d cancd
- newinitd ${FILESDIR}/netconsole-init.d netconsole
- newconfd ${FILESDIR}/netconsole-conf.d netconsole
+ newinitd "${FILESDIR}"/cancd-init.d cancd
+ newconfd "${FILESDIR}"/cancd-conf.d cancd
+ newinitd "${FILESDIR}"/netconsole-init.d netconsole
+ newconfd "${FILESDIR}"/netconsole-conf.d netconsole
keepdir /var/crash
fowners adm:nobody /var/crash
fperms 700 /var/crash
diff --git a/app-admin/cancd/files/cancd-0.1.0-build.patch b/app-admin/cancd/files/cancd-0.1.0-build.patch
new file mode 100644
index 000000000000..b1c99b1cd565
--- /dev/null
+++ b/app-admin/cancd/files/cancd-0.1.0-build.patch
@@ -0,0 +1,14 @@
+fix building with newer glibc
+
+http://bugs.gentoo.org/246734
+
+--- cancd.c
++++ cancd.c
+@@ -36,6 +36,7 @@
+ #include <libgen.h>
+ #include <getopt.h>
+ #include <stdarg.h>
++#include <limits.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <netinet/in.h>