summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-01-14 21:43:23 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-01-14 21:43:23 +0000
commitc79d2318e28d0ccd3277c5d666e428b339a0eb03 (patch)
tree3b19354fb01d1c832f04fc524576b4291bdcf273 /app-admin/cdist
parentia64 stable, bug #494574 (thanks to Emeric Maschino for testing) (diff)
downloadgentoo-2-c79d2318e28d0ccd3277c5d666e428b339a0eb03.tar.gz
gentoo-2-c79d2318e28d0ccd3277c5d666e428b339a0eb03.tar.bz2
gentoo-2-c79d2318e28d0ccd3277c5d666e428b339a0eb03.zip
Version bump to 3.0.1; fixes bug #498052, proxied commit for Daniel Heule (nerve).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-admin/cdist')
-rw-r--r--app-admin/cdist/ChangeLog9
-rw-r--r--app-admin/cdist/cdist-3.0.1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/app-admin/cdist/ChangeLog b/app-admin/cdist/ChangeLog
index 9f2157d2986b..a8595aa12072 100644
--- a/app-admin/cdist/ChangeLog
+++ b/app-admin/cdist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/cdist
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/cdist/ChangeLog,v 1.1 2014/01/09 21:16:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cdist/ChangeLog,v 1.2 2014/01/14 21:43:23 tomwij Exp $
+
+*cdist-3.0.1 (14 Jan 2014)
+
+ 14 Jan 2014; Tom Wijsman <TomWij@gentoo.org> +cdist-3.0.1.ebuild:
+ Version bump to 3.0.1; fixes bug #498052, proxied commit for Daniel Heule
+ (nerve).
*cdist-3.0.0 (09 Jan 2014)
@@ -8,4 +14,3 @@
+metadata.xml:
Initial commit. Ebuild by Daniel Heule <nerve@ipwar.ch> who will maintain it.
Bug #493108
-
diff --git a/app-admin/cdist/cdist-3.0.1.ebuild b/app-admin/cdist/cdist-3.0.1.ebuild
new file mode 100644
index 000000000000..da4ffd66c75c
--- /dev/null
+++ b/app-admin/cdist/cdist-3.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cdist/cdist-3.0.1.ebuild,v 1.1 2014/01/14 21:43:23 tomwij Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3} )
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="http://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-text/asciidoc dev-libs/libxslt"
+RDEPEND="${PYTHON_DEPS}"
+
+DOCS="README"
+
+src_prepare() {
+ rm cdist/conf/.gitignore || die "rm failed"
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ if use doc; then
+ HTML_DOCS="docs/man/man1/*.html docs/man/man7/*.html"
+ fi
+ distutils-r1_src_install
+ doman docs/man/man1/*.1 docs/man/man7/*.7
+}