summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2012-06-17 15:36:21 +0000
committerBenedikt Boehm <hollow@gentoo.org>2012-06-17 15:36:21 +0000
commita1f116b8c9deca1fecdd4702322e7ad370227119 (patch)
tree9b85073b518aeac3e2fe6f3b9e0ae5c7057d308d /app-admin/chef
parentStable for amd64, wrt bug #421565 (diff)
downloadgentoo-2-a1f116b8c9deca1fecdd4702322e7ad370227119.tar.gz
gentoo-2-a1f116b8c9deca1fecdd4702322e7ad370227119.tar.bz2
gentoo-2-a1f116b8c9deca1fecdd4702322e7ad370227119.zip
version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/chef')
-rw-r--r--app-admin/chef/ChangeLog7
-rw-r--r--app-admin/chef/chef-0.10.10.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/app-admin/chef/ChangeLog b/app-admin/chef/ChangeLog
index f59f9f229ed5..934c1c46c52f 100644
--- a/app-admin/chef/ChangeLog
+++ b/app-admin/chef/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/chef
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/ChangeLog,v 1.11 2012/05/31 02:23:21 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/ChangeLog,v 1.12 2012/06/17 15:36:21 hollow Exp $
+
+*chef-0.10.10 (17 Jun 2012)
+
+ 17 Jun 2012; Benedikt Böhm <hollow@gentoo.org> +chef-0.10.10.ebuild:
+ version bump
31 May 2012; Zac Medico <zmedico@gentoo.org> chef-0.10.10_beta1.ebuild,
chef-0.10.2.ebuild, chef-0.10.8.ebuild:
diff --git a/app-admin/chef/chef-0.10.10.ebuild b/app-admin/chef/chef-0.10.10.ebuild
new file mode 100644
index 000000000000..90be6bb03c1a
--- /dev/null
+++ b/app-admin/chef/chef-0.10.10.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/chef-0.10.10.ebuild,v 1.1 2012/06/17 15:36:21 hollow Exp $
+
+EAPI="4"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem user
+
+DESCRIPTION="Chef is a systems integration framework"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/bunny-0.6.0
+ dev-ruby/erubis
+ dev-ruby/highline
+ >=dev-ruby/json-1.4.4
+ <=dev-ruby/json-1.6.1
+ >=dev-ruby/mixlib-authentication-1.1.0
+ >=dev-ruby/mixlib-cli-1.1.0
+ >=dev-ruby/mixlib-config-1.1.2
+ >=dev-ruby/mixlib-log-1.3.0
+ >=dev-ruby/mixlib-shellout-1.0.0
+ dev-ruby/moneta
+ >=dev-ruby/net-ssh-2.2.2
+ <dev-ruby/net-ssh-2.4.0
+ >=dev-ruby/net-ssh-multi-1.1
+ >=dev-ruby/ohai-0.6.0
+ >=dev-ruby/rest-client-1.0.4
+ dev-ruby/ruby-shadow
+ >=dev-ruby/treetop-1.4.9
+ dev-ruby/uuidtools"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/chef /var/lib/chef /var/log/chef /var/run/chef
+
+ doinitd "${FILESDIR}/initd/chef-client"
+ doconfd "${FILESDIR}/confd/chef-client"
+
+ insinto /etc/chef
+ doins "${FILESDIR}/client.rb"
+ doins "${FILESDIR}/solo.rb"
+}
+
+pkg_setup() {
+ enewgroup chef
+ enewuser chef -1 -1 /var/lib/chef chef
+}
+
+pkg_postinst() {
+ elog
+ elog "You should edit /etc/chef/client.rb before starting the service with"
+ elog "/etc/init.d/chef-client start"
+ elog
+}