summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-10-06 19:22:14 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-10-06 19:22:14 +0000
commit4106e5123a9bf304d09946e9f242269755b6dd7a (patch)
tree04e50966a27631080f8cd06c455988de5e5d5cc6 /app-admin/conky
parentVersion bump (to replace policykit with polkit). Fix building wrt #280693 by ... (diff)
downloadgentoo-2-4106e5123a9bf304d09946e9f242269755b6dd7a.tar.gz
gentoo-2-4106e5123a9bf304d09946e9f242269755b6dd7a.tar.bz2
gentoo-2-4106e5123a9bf304d09946e9f242269755b6dd7a.zip
Fix bug #339971. Thanks to Lars Wendler for the report and Brenden Matthews for the fix.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog7
-rw-r--r--app-admin/conky/conky-1.8.1.ebuild8
-rw-r--r--app-admin/conky/files/conky-1.8.1-nvidia-x.patch33
3 files changed, 46 insertions, 2 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index d02805c3ea6c..2f18cf715514 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.143 2010/10/06 16:35:57 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.144 2010/10/06 19:22:14 billie Exp $
+
+ 06 Oct 2010; Daniel Pielmeier <billie@gentoo.org> conky-1.8.1.ebuild,
+ +files/conky-1.8.1-nvidia-x.patch:
+ Fix bug #339971. Thanks to Lars Wendler for the report and Brenden
+ Matthews for the fix.
*conky-1.8.1 (06 Oct 2010)
diff --git a/app-admin/conky/conky-1.8.1.ebuild b/app-admin/conky/conky-1.8.1.ebuild
index 0d6b33eef79b..c04db24aed6f 100644
--- a/app-admin/conky/conky-1.8.1.ebuild
+++ b/app-admin/conky/conky-1.8.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.1.ebuild,v 1.1 2010/10/06 16:35:57 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.1.ebuild,v 1.2 2010/10/06 19:22:14 billie Exp $
EAPI=2
+inherit eutils
+
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="http://conky.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
@@ -50,6 +52,10 @@ DEPEND="
dev-util/pkgconfig
"
+src_prepare() {
+ epatch "${FILESDIR}/conky-1.8.1-nvidia-x.patch"
+}
+
src_configure() {
local myconf
diff --git a/app-admin/conky/files/conky-1.8.1-nvidia-x.patch b/app-admin/conky/files/conky-1.8.1-nvidia-x.patch
new file mode 100644
index 000000000000..b56cee5f9795
--- /dev/null
+++ b/app-admin/conky/files/conky-1.8.1-nvidia-x.patch
@@ -0,0 +1,33 @@
+From b72004787038371098a745c9358e8e1552d945d5 Mon Sep 17 00:00:00 2001
+From: Brenden Matthews <brenden@diddyinc.com>
+Date: Wed, 6 Oct 2010 11:49:27 -0700
+Subject: [PATCH] Bulid fix for nvidia support.
+
+See http://bugs.gentoo.org/show_bug.cgi?id=339971 for details.
+---
+ src/nvidia.c | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/src/nvidia.c b/src/nvidia.c
+index 8a6423e..5f378d8 100644
+--- a/src/nvidia.c
++++ b/src/nvidia.c
+@@ -32,6 +32,7 @@
+ #include "logging.h"
+ #include "nvidia.h"
+ #include "temphelper.h"
++#include "x11.h"
+ #include <NVCtrl/NVCtrlLib.h>
+
+ const int nvidia_query_to_attr[] = {NV_CTRL_GPU_CORE_TEMPERATURE,
+@@ -145,5 +146,6 @@ void set_nvidia_display(const char *disp)
+ if ((nvdisplay = XOpenDisplay(disp)) == NULL) {
+ CRIT_ERR(NULL, NULL, "can't open nvidia display: %s", XDisplayName(disp));
+ }
+- }
++ }
+ }
++
+--
+1.7.0.4
+