summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-11-28 07:03:32 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-11-28 07:03:32 +0000
commit6c59c57efe76a1b322bedad08590f07eb20bc39e (patch)
treed56e97eb9368713749646bbed50bba519edddf3e /app-admin/conky
parentStable on x86, bug #113289. (diff)
downloadgentoo-2-6c59c57efe76a1b322bedad08590f07eb20bc39e.tar.gz
gentoo-2-6c59c57efe76a1b322bedad08590f07eb20bc39e.tar.bz2
gentoo-2-6c59c57efe76a1b322bedad08590f07eb20bc39e.zip
removed seti support - bug #113759
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog6
-rw-r--r--app-admin/conky/conky-1.3.1.ebuild14
-rw-r--r--app-admin/conky/conky-1.3.3.ebuild14
-rw-r--r--app-admin/conky/conky-1.3.4-r1.ebuild14
4 files changed, 21 insertions, 27 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index a9973e28e955..5e09e6bec65e 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.13 2005/11/25 11:31:29 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.14 2005/11/28 07:03:32 dragonheart Exp $
+
+ 28 Nov 2005; Daniel Black <dragonheart@gentoo.org> conky-1.3.1.ebuild,
+ conky-1.3.3.ebuild, conky-1.3.4-r1.ebuild:
+ removed seti support - bug #113759
25 Nov 2005; Daniel Black <dragonheart@gentoo.org>
files/conky-1.3.4-miscbug.patch:
diff --git a/app-admin/conky/conky-1.3.1.ebuild b/app-admin/conky/conky-1.3.1.ebuild
index 5ba58e8076a8..bd8e1da31ed5 100644
--- a/app-admin/conky/conky-1.3.1.ebuild
+++ b/app-admin/conky/conky-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.1.ebuild,v 1.1 2005/09/12 22:10:21 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.1.ebuild,v 1.2 2005/11/28 07:03:32 dragonheart Exp $
DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
HOMEPAGE="http://conky.sf.net"
@@ -9,20 +9,17 @@ SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="truetype seti X"
+IUSE="truetype X"
-DEPEND_COMMON="
+RDEPEND="
virtual/libc
X? (
virtual/x11
truetype? ( >=media-libs/freetype-2 )
)"
-RDEPEND="${DEPEND_COMMON}
- seti? ( sci-astronomy/setiathome )"
-
DEPEND="
- ${DEPEND_COMMON}
+ ${RDEPEND}
>=sys-devel/automake-1.9
>=sys-devel/autoconf-2.59
sys-devel/libtool
@@ -38,8 +35,7 @@ src_compile() {
econf \
${myconf} \
$(use_enable truetype xft) \
- $(use_enable X x11) \
- $(use_enable seti) || die "econf failed"
+ $(use_enable X x11) || die "econf failed"
emake || die "compile failed"
}
diff --git a/app-admin/conky/conky-1.3.3.ebuild b/app-admin/conky/conky-1.3.3.ebuild
index 79768fc53149..0a3ed85209ed 100644
--- a/app-admin/conky/conky-1.3.3.ebuild
+++ b/app-admin/conky/conky-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.3.ebuild,v 1.1 2005/10/18 11:57:09 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.3.ebuild,v 1.2 2005/11/28 07:03:32 dragonheart Exp $
inherit eutils
@@ -11,20 +11,17 @@ SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="truetype seti X"
+IUSE="truetype X"
-DEPEND_COMMON="
+RDEPEND="
virtual/libc
X? (
virtual/x11
truetype? ( >=media-libs/freetype-2 )
)"
-RDEPEND="${DEPEND_COMMON}
- seti? ( sci-astronomy/setiathome )"
-
DEPEND="
- ${DEPEND_COMMON}
+ ${RDEPEND}
>=sys-devel/automake-1.9
>=sys-devel/autoconf-2.59
sys-devel/libtool
@@ -40,8 +37,7 @@ src_compile() {
econf \
${myconf} \
$(use_enable truetype xft) \
- $(use_enable X x11) \
- $(use_enable seti) || die "econf failed"
+ $(use_enable X x11) || die "econf failed"
emake || die "compile failed"
}
diff --git a/app-admin/conky/conky-1.3.4-r1.ebuild b/app-admin/conky/conky-1.3.4-r1.ebuild
index 117760eee975..eea991fb05c0 100644
--- a/app-admin/conky/conky-1.3.4-r1.ebuild
+++ b/app-admin/conky/conky-1.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.4-r1.ebuild,v 1.1 2005/11/25 08:36:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.3.4-r1.ebuild,v 1.2 2005/11/28 07:03:32 dragonheart Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="truetype seti X ipv6"
+IUSE="truetype X ipv6"
DEPEND_COMMON="
virtual/libc
@@ -20,13 +20,11 @@ DEPEND_COMMON="
truetype? ( >=media-libs/freetype-2 )
)"
-RDEPEND="${DEPEND_COMMON}
- seti? ( sci-astronomy/setiathome )"
+RDEPEND="${DEPEND_COMMON}"
+# seti? ( sci-astronomy/setiathome )"
DEPEND="
${DEPEND_COMMON}
- >=sys-devel/automake-1.9
- >=sys-devel/autoconf-2.59
sys-devel/libtool
sys-apps/grep
sys-apps/sed
@@ -57,8 +55,8 @@ src_compile() {
${myconf} \
$(use_enable truetype xft) \
$(use_enable X x11) \
- $(use_enable !ipv6 portmon) \
- $(use_enable seti) || die "econf failed"
+ $(use_enable !ipv6 portmon) || die "econf failed"
+# $(use_enable seti)
emake ${mymake} || die "compile failed"
}