summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2011-08-06 23:14:18 +0000
committerDaniel Pielmeier <billie@gentoo.org>2011-08-06 23:14:18 +0000
commitbc6e26833ff13510b01531e53f9b2dbc259196de (patch)
tree6b759adbe009efe4c7ac2c4c0569d6bb5aea5d68 /app-admin/conky
parentAdd ruby19 to the list of supported targets. (diff)
downloadgentoo-2-bc6e26833ff13510b01531e53f9b2dbc259196de.tar.gz
gentoo-2-bc6e26833ff13510b01531e53f9b2dbc259196de.tar.bz2
gentoo-2-bc6e26833ff13510b01531e53f9b2dbc259196de.zip
Add patch to increase the number of maximum network devices. This fixes bug #365287. Thanks to Markos Chandras for the report.
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog7
-rw-r--r--app-admin/conky/conky-1.8.0-r1.ebuild5
-rw-r--r--app-admin/conky/conky-1.8.1-r2.ebuild8
-rw-r--r--app-admin/conky/files/conky-1.8.1-maxinterfaces.patch13
4 files changed, 27 insertions, 6 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 524a4ad7e1ef..313ef908853f 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.164 2011/07/29 06:40:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.165 2011/08/06 23:14:18 billie Exp $
+
+ 06 Aug 2011; Daniel Pielmeier <billie@gentoo.org> conky-1.8.0-r1.ebuild,
+ conky-1.8.1-r2.ebuild, +files/conky-1.8.1-maxinterfaces.patch:
+ Add patch to increase the number of maximum network devices. This fixes bug
+ #365287. Thanks to Markos Chandras for the report.
29 Jul 2011; Christoph Mende <angelos@gentoo.org> conky-1.8.0-r1.ebuild,
conky-1.8.1-r2.ebuild, +files/conky-1.8.1-curl-headers.patch:
diff --git a/app-admin/conky/conky-1.8.0-r1.ebuild b/app-admin/conky/conky-1.8.0-r1.ebuild
index dbcb144452f1..a36ba4186093 100644
--- a/app-admin/conky/conky-1.8.0-r1.ebuild
+++ b/app-admin/conky/conky-1.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.0-r1.ebuild,v 1.9 2011/07/29 06:40:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.0-r1.ebuild,v 1.10 2011/08/06 23:14:18 billie Exp $
EAPI="2"
@@ -54,7 +54,8 @@ DEPEND="
src_prepare() {
epatch "${FILESDIR}/conky-1.8.0-ncurses.patch" \
"${FILESDIR}/conky-1.8.0-audacious-2.3.patch" \
- "${FILESDIR}/${PN}-1.8.1-curl-headers.patch"
+ "${FILESDIR}/${PN}-1.8.1-curl-headers.patch" \
+ "${FILESDIR}/${PN}-1.8.1-maxinterfaces.patch"
eautoreconf
}
diff --git a/app-admin/conky/conky-1.8.1-r2.ebuild b/app-admin/conky/conky-1.8.1-r2.ebuild
index 4e31a8cce1ff..a2c21f88e441 100644
--- a/app-admin/conky/conky-1.8.1-r2.ebuild
+++ b/app-admin/conky/conky-1.8.1-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.1-r2.ebuild,v 1.7 2011/07/29 06:40:00 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.8.1-r2.ebuild,v 1.8 2011/08/06 23:14:18 billie Exp $
EAPI=2
-inherit eutils
+inherit autotools eutils
DESCRIPTION="An advanced, highly configurable system monitor for X"
HOMEPAGE="http://conky.sourceforge.net/"
@@ -57,7 +57,9 @@ src_prepare() {
"${FILESDIR}/${P}-xmms2.patch" \
"${FILESDIR}/${P}-secunia-SA43225.patch" \
"${FILESDIR}/${P}-acpitemp.patch" \
- "${FILESDIR}/${P}-curl-headers.patch"
+ "${FILESDIR}/${P}-curl-headers.patch" \
+ "${FILESDIR}/${P}-maxinterfaces.patch"
+ eautoreconf
}
src_configure() {
diff --git a/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch b/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch
new file mode 100644
index 000000000000..41bb9584ab12
--- /dev/null
+++ b/app-admin/conky/files/conky-1.8.1-maxinterfaces.patch
@@ -0,0 +1,13 @@
+Index: conky-1.8.1/configure.ac
+===================================================================
+--- conky-1.8.1.orig/configure.ac
++++ conky-1.8.1/configure.ac
+@@ -790,7 +790,7 @@ AC_DEFINE(CONFIG_FILE, "$HOME/.conkyrc",
+ AC_DEFINE(MAX_SPECIALS_DEFAULT, 512, [Default maximum number of special things, e.g. fonts, offsets, aligns, etc.])
+ AC_DEFINE(MAX_USER_TEXT_DEFAULT, 16384, [Default maximum size of config TEXT buffer, i.e. below TEXT line.])
+ AC_DEFINE(DEFAULT_TEXT_BUFFER_SIZE, 256, [Default size used for temporary, static text buffers])
+-AC_DEFINE(MAX_NET_INTERFACES, 16, [Maximum number of network devices])
++AC_DEFINE(MAX_NET_INTERFACES, 64, [Maximum number of network devices])
+
+ dnl
+ dnl Some functions