summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2012-12-25 04:36:13 +0000
committerLance Albertson <ramereth@gentoo.org>2012-12-25 04:36:13 +0000
commit4e3226d31b21259f94e455a6b63ff0be0849031f (patch)
tree80d00c786af064b3b5709a20d6e24722e21ecba4 /app-admin/drush/drush-5.8.ebuild
parentVersion bump, fix init script, fixes #448298 & #436268 (diff)
downloadgentoo-2-4e3226d31b21259f94e455a6b63ff0be0849031f.tar.gz
gentoo-2-4e3226d31b21259f94e455a6b63ff0be0849031f.tar.bz2
gentoo-2-4e3226d31b21259f94e455a6b63ff0be0849031f.zip
Version bump, cleanup, mark stable (resolves #432786)
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 27F4B742)
Diffstat (limited to 'app-admin/drush/drush-5.8.ebuild')
-rw-r--r--app-admin/drush/drush-5.8.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-admin/drush/drush-5.8.ebuild b/app-admin/drush/drush-5.8.ebuild
new file mode 100644
index 000000000000..52c92a93b2ab
--- /dev/null
+++ b/app-admin/drush/drush-5.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/drush-5.8.ebuild,v 1.1 2012/12/25 04:36:13 ramereth Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1
+
+DESCRIPTION="Drush is a command line shell and scripting interface for Drupal"
+HOMEPAGE="http://drupal.org/project/drush"
+SRC_URI="http://ftp.drupal.org/files/projects/${PN}-7.x-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+
+DEPEND="dev-lang/php[cli,simplexml]
+ dev-php/pear
+ dev-php/PEAR-Console_Table
+ dev-php/PEAR-Console_Getopt"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.txt!\0.bz2!g" \
+ includes/bootstrap.inc || die
+ sed -i \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ commands/core/docs.drush.inc || die
+ sed \
+ -e "1,2d" \
+ -e "5,11d" \
+ drush.complete.sh > drush.bashcomp
+}
+
+src_install() {
+ local docs="README.txt docs"
+ use examples && docs="${docs} examples"
+ insinto /usr/share/drush
+ doins -r .
+ exeinto /usr/share/drush
+ doexe drush
+ dosym /usr/share/drush/drush /usr/bin/drush
+ dodoc -r ${docs}
+ # cleanup
+ for i in ${docs} LICENSE.txt drush.bat examples includes/.gitignore \
+ .gitignore .travis.yml drush.complete.sh ; do
+ rm -rf "${D}/usr/share/drush/${i}"
+ done
+ keepdir /etc/drush
+ newbashcomp drush.bashcomp drush
+}