summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-08-12 09:30:46 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-08-12 09:30:46 +0000
commit08484cbeb907d114000437273c7c441ba3f9503e (patch)
tree82cbb5035bdc7816a567f096d85f0e0f8d245f7d /app-admin/equo/equo-1.0_rc38.ebuild
parentversion bump (diff)
downloadgentoo-2-08484cbeb907d114000437273c7c441ba3f9503e.tar.gz
gentoo-2-08484cbeb907d114000437273c7c441ba3f9503e.tar.bz2
gentoo-2-08484cbeb907d114000437273c7c441ba3f9503e.zip
version bump
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/equo/equo-1.0_rc38.ebuild')
-rw-r--r--app-admin/equo/equo-1.0_rc38.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/equo/equo-1.0_rc38.ebuild b/app-admin/equo/equo-1.0_rc38.ebuild
new file mode 100644
index 000000000000..6b0aff0ae138
--- /dev/null
+++ b/app-admin/equo/equo-1.0_rc38.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-1.0_rc38.ebuild,v 1.1 2011/08/12 09:30:46 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ dobashcompletion "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ bash-completion_pkg_postinst
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/entropy-client-services"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}