summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-04-02 09:33:56 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-04-02 09:33:56 +0000
commitb2bb50d10fcc7fe62efc104e2947c5ee734a7c31 (patch)
tree6ee2c4fca488d4c11bd55eae0f5e56ff30855ce4 /app-admin/equo
parentversion bump (diff)
downloadgentoo-2-b2bb50d10fcc7fe62efc104e2947c5ee734a7c31.tar.gz
gentoo-2-b2bb50d10fcc7fe62efc104e2947c5ee734a7c31.tar.bz2
gentoo-2-b2bb50d10fcc7fe62efc104e2947c5ee734a7c31.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key ADC916E5)
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-189.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index f230a8b6f3a5..2ac062ea6ba6 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.24 2013/03/14 18:09:19 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.25 2013/04/02 09:33:56 lxnay Exp $
+
+*equo-189 (02 Apr 2013)
+
+ 02 Apr 2013; Fabio Erculiani <lxnay@gentoo.org> +equo-189.ebuild:
+ version bump
*equo-183 (14 Mar 2013)
diff --git a/app-admin/equo/equo-189.ebuild b/app-admin/equo/equo-189.ebuild
new file mode 100644
index 000000000000..c14659f8855a
--- /dev/null
+++ b/app-admin/equo/equo-189.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-189.ebuild,v 1.1 2013/04/02 09:33:56 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ cd "${S}"/client || die
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/client || die
+ emake DESTDIR="${D}" LIBDIR="usr/lib" install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/rigo-daemon"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}