summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-01 07:16:25 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-01 07:16:25 +0000
commit67fa664c6b9bfaec85cbf3afca3e425f5e5eef64 (patch)
tree4dc9bb86a82dafa46954cefeec9de0f9c57160b7 /app-admin/eselect-wxwidgets
parentFix installing of example channels.conf files. (diff)
downloadgentoo-2-67fa664c6b9bfaec85cbf3afca3e425f5e5eef64.tar.gz
gentoo-2-67fa664c6b9bfaec85cbf3afca3e425f5e5eef64.tar.bz2
gentoo-2-67fa664c6b9bfaec85cbf3afca3e425f5e5eef64.zip
Version bump. Debashify wx-config and wxrc wrappers for compatibility with
cmake (bug #274675). (Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/eselect-wxwidgets')
-rw-r--r--app-admin/eselect-wxwidgets/ChangeLog9
-rw-r--r--app-admin/eselect-wxwidgets/eselect-wxwidgets-1.0.ebuild46
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wx-config-135
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wxrc-135
4 files changed, 124 insertions, 1 deletions
diff --git a/app-admin/eselect-wxwidgets/ChangeLog b/app-admin/eselect-wxwidgets/ChangeLog
index 07442b72824b..6341cbed1138 100644
--- a/app-admin/eselect-wxwidgets/ChangeLog
+++ b/app-admin/eselect-wxwidgets/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/eselect-wxwidgets
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/ChangeLog,v 1.35 2009/01/22 12:49:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/ChangeLog,v 1.36 2009/07/01 07:16:25 dirtyepic Exp $
+
+*eselect-wxwidgets-1.0 (01 Jul 2009)
+
+ 01 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> +files/wx-config-1,
+ +files/wxrc-1, +eselect-wxwidgets-1.0.ebuild:
+ Version bump. Debashify wx-config and wxrc wrappers for compatibility with
+ cmake (bug #274675).
22 Jan 2009; Raúl Porcel <armin76@gentoo.org>
eselect-wxwidgets-0.8.ebuild:
diff --git a/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.0.ebuild b/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.0.ebuild
new file mode 100644
index 000000000000..1a7fde538948
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.0.ebuild,v 1.1 2009/07/01 07:16:25 dirtyepic Exp $
+
+DESCRIPTION="Eselect module and wrappers for wxWidgets"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!<=x11-libs/wxGTK-2.6.4.0-r2"
+RDEPEND="app-admin/eselect"
+
+WXWRAP_VER=1
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/wxwidgets.eselect-0.8 wxwidgets.eselect \
+ || die "Failed installing module"
+
+ insinto /usr/share/aclocal
+ doins "${FILESDIR}"/wxwin.m4
+
+ newbin "${FILESDIR}"/wx-config-${WXWRAP_VER} wx-config
+ newbin "${FILESDIR}"/wxrc-${WXWRAP_VER} wxrc
+
+ keepdir /var/lib/wxwidgets
+ keepdir /usr/share/bakefile/presets
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/var/lib/wxwidgets/current ]]; then
+ echo 'WXCONFIG="none"' > "${ROOT}"/var/lib/wxwidgets/current
+ fi
+
+ echo
+ elog "By default the system wxWidgets profile is set to \"none\"."
+ elog
+ elog "It is unnecessary to change this unless you are doing development work"
+ elog "with wxGTK outside of portage. The package manager ignores the profile"
+ elog "setting altogether."
+ echo
+}
diff --git a/app-admin/eselect-wxwidgets/files/wx-config-1 b/app-admin/eselect-wxwidgets/files/wx-config-1
new file mode 100755
index 000000000000..559434bc2c77
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/files/wx-config-1
@@ -0,0 +1,35 @@
+#!/bin/sh -
+#
+# /usr/bin/wx-config
+#
+# a lame wx-config wrapper (bugs to wxwidgets@gentoo.org)
+
+_wxerror() {
+ echo "An error occurred while calling wx-config:"
+ echo
+ echo " ${1}"
+ echo
+ echo "Please use \`eselect wxwidgets\` to select an available profile and try again."
+ exit 1
+}
+
+if [ -n "${WX_ECLASS_CONFIG}" ]; then
+ ${WX_ECLASS_CONFIG} "$@"
+ exit 0
+else
+ if [ -e /var/lib/wxwidgets/current ]; then
+ source /var/lib/wxwidgets/current
+ else
+ _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
+ fi
+
+ [ -z "${WXCONFIG}" -o "${WXCONFIG}" == none ] && _wxerror "No profile currently selected"
+
+ if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
+ /usr/lib/wx/config/${WXCONFIG} "$@"
+ else
+ _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
+ fi
+ exit 0
+fi
+
diff --git a/app-admin/eselect-wxwidgets/files/wxrc-1 b/app-admin/eselect-wxwidgets/files/wxrc-1
new file mode 100755
index 000000000000..cf755dad178e
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/files/wxrc-1
@@ -0,0 +1,35 @@
+#!/bin/sh -
+#
+# /usr/bin/wxrc
+#
+# a lame wxrc wrapper (bugs to wxwidgets@gentoo.org)
+
+_wxerror() {
+ echo "An error occurred while calling wxrc:"
+ echo
+ echo " ${1}"
+ echo
+ echo "Please use \`eselect wxwidgets\` to select an available profile and try again."
+ exit 1
+}
+
+if [ -n "${WX_ECLASS_CONFIG}" ]; then
+ $(${WX_ECLASS_CONFIG} --utility=wxrc) "$@"
+ exit 0
+else
+ if [ -e /var/lib/wxwidgets/current ]; then
+ source /var/lib/wxwidgets/current
+ else
+ _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
+ fi
+
+ [ -z "${WXCONFIG}" -o "${WXCONFIG}" == none ] && _wxerror "No profile currently selected"
+
+ if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
+ $(/usr/lib/wx/config/${WXCONFIG} --utility=wxrc) "$@"
+ else
+ _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
+ fi
+ exit 0
+fi
+