summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-01-24 21:45:08 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-01-24 21:45:08 +0000
commita310c0f52ef15fee4eeefda29564ec4a9043567d (patch)
tree88db9ad64784a3c3c31b84e9cf8889f566b62b9e /app-admin/eselect-wxwidgets
parentFilter ecj-3.5 (diff)
downloadgentoo-2-a310c0f52ef15fee4eeefda29564ec4a9043567d.tar.gz
gentoo-2-a310c0f52ef15fee4eeefda29564ec4a9043567d.tar.bz2
gentoo-2-a310c0f52ef15fee4eeefda29564ec4a9043567d.zip
Fix bashisms in wrapper scripts. Bug #301778 by Anthony Parsons.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/eselect-wxwidgets')
-rw-r--r--app-admin/eselect-wxwidgets/ChangeLog10
-rw-r--r--app-admin/eselect-wxwidgets/eselect-wxwidgets-1.3.ebuild51
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wx-config-1.338
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wxrc-1.338
4 files changed, 135 insertions, 2 deletions
diff --git a/app-admin/eselect-wxwidgets/ChangeLog b/app-admin/eselect-wxwidgets/ChangeLog
index 597f4459e122..20d32e087dd0 100644
--- a/app-admin/eselect-wxwidgets/ChangeLog
+++ b/app-admin/eselect-wxwidgets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-wxwidgets
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/ChangeLog,v 1.44 2009/11/13 01:48:24 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/ChangeLog,v 1.45 2010/01/24 21:45:06 dirtyepic Exp $
+
+*eselect-wxwidgets-1.3 (24 Jan 2010)
+
+ 24 Jan 2010; Ryan Hill <dirtyepic@gentoo.org> +files/wx-config-1.3,
+ +files/wxrc-1.3, +eselect-wxwidgets-1.3.ebuild:
+ Fix bashisms in wrapper scripts. Bug #301778 by Anthony Parsons.
*eselect-wxwidgets-1.2 (13 Nov 2009)
diff --git a/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.3.ebuild b/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.3.ebuild
new file mode 100644
index 000000000000..a3be2d3aea58
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.3.ebuild,v 1.1 2010/01/24 21:45:06 dirtyepic Exp $
+
+WXWRAP_VER=1.3
+WXESELECT_VER=1.2
+
+DESCRIPTION="Eselect module and wrappers for wxWidgets"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="mirror://gentoo/wxwidgets.eselect-${WXESELECT_VER}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!<=x11-libs/wxGTK-2.6.4.0-r2"
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${S}"/wxwidgets.eselect-${WXESELECT_VER} wxwidgets.eselect \
+ || die "Failed installing module"
+
+ insinto /usr/share/aclocal
+ doins "${FILESDIR}"/wxwin.m4 || die "Failed installing m4"
+
+ newbin "${FILESDIR}"/wx-config-${WXWRAP_VER} wx-config \
+ || die "Failed installing wx-config"
+ newbin "${FILESDIR}"/wxrc-${WXWRAP_VER} wxrc \
+ || die "Failed installing wxrc"
+
+ keepdir /var/lib/wxwidgets
+ keepdir /usr/share/bakefile/presets
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/var/lib/wxwidgets/current ]]; then
+ echo 'WXCONFIG="none"' > "${ROOT}"/var/lib/wxwidgets/current
+ fi
+
+ echo
+ elog "By default the system wxWidgets profile is set to \"none\"."
+ elog
+ elog "It is unnecessary to change this unless you are doing development work"
+ elog "with wxGTK outside of portage. The package manager ignores the profile"
+ elog "setting altogether."
+ echo
+}
diff --git a/app-admin/eselect-wxwidgets/files/wx-config-1.3 b/app-admin/eselect-wxwidgets/files/wx-config-1.3
new file mode 100755
index 000000000000..e61cdcac5608
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/files/wx-config-1.3
@@ -0,0 +1,38 @@
+#!/bin/sh -
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wx-config-1.3,v 1.1 2010/01/24 21:45:08 dirtyepic Exp $
+#
+# /usr/bin/wx-config
+#
+# a lame wx-config wrapper (bugs to wxwidgets@gentoo.org)
+
+_wxerror() {
+ cat >&2 <<- EOF
+ An error occurred while calling wx-config:
+
+ ${1}
+
+ Please use \`eselect wxwidgets\` to select an available profile and try again.
+ EOF
+ exit 1
+}
+
+if [ -n "${WX_ECLASS_CONFIG}" ]; then
+ ${WX_ECLASS_CONFIG} "$@"
+ exit 0
+else
+ if [ -e /var/lib/wxwidgets/current ]; then
+ . /var/lib/wxwidgets/current
+ else
+ _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
+ fi
+
+ [ -z "${WXCONFIG}" -o "${WXCONFIG}" = none ] && _wxerror "No profile currently selected"
+
+ if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
+ /usr/lib/wx/config/${WXCONFIG} "$@"
+ else
+ _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
+ fi
+ exit 0
+fi
+
diff --git a/app-admin/eselect-wxwidgets/files/wxrc-1.3 b/app-admin/eselect-wxwidgets/files/wxrc-1.3
new file mode 100755
index 000000000000..7b55f43f0408
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/files/wxrc-1.3
@@ -0,0 +1,38 @@
+#!/bin/sh -
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wxrc-1.3,v 1.1 2010/01/24 21:45:08 dirtyepic Exp $
+#
+# /usr/bin/wxrc
+#
+# a lame wxrc wrapper (bugs to wxwidgets@gentoo.org)
+
+_wxerror() {
+ cat >&2 <<- EOF
+ An error occurred while calling wxrc:
+
+ ${1}
+
+ Please use \`eselect wxwidgets\` to select an available profile and try again.
+ EOF
+ exit 1
+}
+
+if [ -n "${WX_ECLASS_CONFIG}" ]; then
+ $(${WX_ECLASS_CONFIG} --utility=wxrc) "$@"
+ exit 0
+else
+ if [ -e /var/lib/wxwidgets/current ]; then
+ . /var/lib/wxwidgets/current
+ else
+ _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
+ fi
+
+ [ -z "${WXCONFIG}" -o "${WXCONFIG}" = none ] && _wxerror "No profile currently selected"
+
+ if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
+ $(/usr/lib/wx/config/${WXCONFIG} --utility=wxrc) "$@"
+ else
+ _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
+ fi
+ exit 0
+fi
+