summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-07-19 02:56:08 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-07-19 02:56:08 +0000
commitc4b831cf4eeb1b6a36ebfa568e4f400706e6b253 (patch)
treed61509d78a0a53aca9b9afef69424daafee948a7 /app-admin/eselect-wxwidgets
parentAdd a warning about gcc-4.4 not being supported by the NVIDIA CUDA compiler (... (diff)
downloadgentoo-2-c4b831cf4eeb1b6a36ebfa568e4f400706e6b253.tar.gz
gentoo-2-c4b831cf4eeb1b6a36ebfa568e4f400706e6b253.tar.bz2
gentoo-2-c4b831cf4eeb1b6a36ebfa568e4f400706e6b253.zip
Direct error messages from the wrappers to stderr as suggested by
Martin von Gagern in bug #278037. (Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/eselect-wxwidgets')
-rw-r--r--app-admin/eselect-wxwidgets/ChangeLog9
-rw-r--r--app-admin/eselect-wxwidgets/eselect-wxwidgets-1.1.ebuild46
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wx-config-1.138
-rwxr-xr-xapp-admin/eselect-wxwidgets/files/wxrc-1.138
4 files changed, 130 insertions, 1 deletions
diff --git a/app-admin/eselect-wxwidgets/ChangeLog b/app-admin/eselect-wxwidgets/ChangeLog
index 4b21847b7573..e71bbca2a6cb 100644
--- a/app-admin/eselect-wxwidgets/ChangeLog
+++ b/app-admin/eselect-wxwidgets/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/eselect-wxwidgets
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/ChangeLog,v 1.37 2009/07/02 19:45:47 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/ChangeLog,v 1.38 2009/07/19 02:56:08 dirtyepic Exp $
+
+*eselect-wxwidgets-1.1 (19 Jul 2009)
+
+ 19 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> +files/wx-config-1.1,
+ +files/wxrc-1.1, +eselect-wxwidgets-1.1.ebuild:
+ Direct error messages from the wrappers to stderr as suggested by
+ Martin von Gagern in bug #278037.
02 Jul 2009; Fabian Groffen <grobian@gentoo.org> files/wx-config-1,
files/wxrc-1:
diff --git a/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.1.ebuild b/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.1.ebuild
new file mode 100644
index 000000000000..63bb0f02d4c6
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/eselect-wxwidgets-1.1.ebuild,v 1.1 2009/07/19 02:56:08 dirtyepic Exp $
+
+DESCRIPTION="Eselect module and wrappers for wxWidgets"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!<=x11-libs/wxGTK-2.6.4.0-r2"
+RDEPEND="app-admin/eselect"
+
+WXWRAP_VER=1.1
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/wxwidgets.eselect-0.8 wxwidgets.eselect \
+ || die "Failed installing module"
+
+ insinto /usr/share/aclocal
+ doins "${FILESDIR}"/wxwin.m4
+
+ newbin "${FILESDIR}"/wx-config-${WXWRAP_VER} wx-config
+ newbin "${FILESDIR}"/wxrc-${WXWRAP_VER} wxrc
+
+ keepdir /var/lib/wxwidgets
+ keepdir /usr/share/bakefile/presets
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/var/lib/wxwidgets/current ]]; then
+ echo 'WXCONFIG="none"' > "${ROOT}"/var/lib/wxwidgets/current
+ fi
+
+ echo
+ elog "By default the system wxWidgets profile is set to \"none\"."
+ elog
+ elog "It is unnecessary to change this unless you are doing development work"
+ elog "with wxGTK outside of portage. The package manager ignores the profile"
+ elog "setting altogether."
+ echo
+}
diff --git a/app-admin/eselect-wxwidgets/files/wx-config-1.1 b/app-admin/eselect-wxwidgets/files/wx-config-1.1
new file mode 100755
index 000000000000..03f20f3bad7f
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/files/wx-config-1.1
@@ -0,0 +1,38 @@
+#!/bin/sh -
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wx-config-1.1,v 1.1 2009/07/19 02:56:08 dirtyepic Exp $
+#
+# /usr/bin/wx-config
+#
+# a lame wx-config wrapper (bugs to wxwidgets@gentoo.org)
+
+_wxerror() {
+ cat >&2 <<- EOF
+ An error occurred while calling wx-config:
+
+ ${1}
+
+ Please use \`eselect wxwidgets\` to select an available profile and try again.
+ EOF
+ exit 1
+}
+
+if [ -n "${WX_ECLASS_CONFIG}" ]; then
+ ${WX_ECLASS_CONFIG} "$@"
+ exit 0
+else
+ if [ -e /var/lib/wxwidgets/current ]; then
+ source /var/lib/wxwidgets/current
+ else
+ _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
+ fi
+
+ [ -z "${WXCONFIG}" -o "${WXCONFIG}" == none ] && _wxerror "No profile currently selected"
+
+ if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
+ /usr/lib/wx/config/${WXCONFIG} "$@"
+ else
+ _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
+ fi
+ exit 0
+fi
+
diff --git a/app-admin/eselect-wxwidgets/files/wxrc-1.1 b/app-admin/eselect-wxwidgets/files/wxrc-1.1
new file mode 100755
index 000000000000..9cca21e3d5ca
--- /dev/null
+++ b/app-admin/eselect-wxwidgets/files/wxrc-1.1
@@ -0,0 +1,38 @@
+#!/bin/sh -
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-wxwidgets/files/wxrc-1.1,v 1.1 2009/07/19 02:56:08 dirtyepic Exp $
+#
+# /usr/bin/wxrc
+#
+# a lame wxrc wrapper (bugs to wxwidgets@gentoo.org)
+
+_wxerror() {
+ cat >&2 <<- EOF
+ An error occurred while calling wxrc:
+
+ ${1}
+
+ Please use \`eselect wxwidgets\` to select an available profile and try again.
+ EOF
+ exit 1
+}
+
+if [ -n "${WX_ECLASS_CONFIG}" ]; then
+ $(${WX_ECLASS_CONFIG} --utility=wxrc) "$@"
+ exit 0
+else
+ if [ -e /var/lib/wxwidgets/current ]; then
+ source /var/lib/wxwidgets/current
+ else
+ _wxerror "Cannot find the wxWidgets profile configuration ( /var/lib/wxwidgets/current )"
+ fi
+
+ [ -z "${WXCONFIG}" -o "${WXCONFIG}" == none ] && _wxerror "No profile currently selected"
+
+ if [ -x /usr/lib/wx/config/${WXCONFIG} ]; then
+ $(/usr/lib/wx/config/${WXCONFIG} --utility=wxrc) "$@"
+ else
+ _wxerror "Cannot find wxWidgets profile ( ${WXCONFIG} )"
+ fi
+ exit 0
+fi
+