summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-02 17:42:01 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-02 17:42:01 +0000
commit5a2d108fa739db76361e7180b2f7d027032a6d38 (patch)
treecf7faac0f0477f9b54744e6b97de1ba0f67c1b22 /app-admin/hddtemp
parentAdded missing dependency. Fixes bug #507746. Thanks to 'Small_Penguin' (diff)
downloadgentoo-2-5a2d108fa739db76361e7180b2f7d027032a6d38.tar.gz
gentoo-2-5a2d108fa739db76361e7180b2f7d027032a6d38.tar.bz2
gentoo-2-5a2d108fa739db76361e7180b2f7d027032a6d38.zip
Use readme.gentoo.eclass (#509382)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-admin/hddtemp')
-rw-r--r--app-admin/hddtemp/ChangeLog6
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild36
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild40
3 files changed, 42 insertions, 40 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index a10ef8209cfa..ba038a2fb75a 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/hddtemp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.154 2014/04/27 11:11:29 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.155 2014/05/02 17:42:01 pacho Exp $
+
+ 02 May 2014; Pacho Ramos <pacho@gentoo.org> hddtemp-0.3_beta15-r25.ebuild,
+ hddtemp-0.3_beta15-r7.ebuild:
+ Use readme.gentoo.eclass (#509382)
*hddtemp-0.3_beta15-r25 (27 Apr 2014)
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
index d9191a9ac16d..a7a300af09a9 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild,v 1.1 2014/04/27 11:11:29 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild,v 1.2 2014/05/02 17:42:01 pacho Exp $
EAPI=5
-
-inherit eutils autotools systemd
+inherit eutils autotools readme.gentoo systemd
MY_P=${P/_beta/-beta}
DBV=20080531
@@ -25,6 +24,19 @@ S="${WORKDIR}/${MY_P}"
DOCS=(README TODO ChangeLog)
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="In order to update your hddtemp database, run:
+emerge --config =${CATEGORY}/${PF} or update-hddtemp.db (if USE
+network-cron is enabled)
+
+If your hard drive is not recognized by hddtemp, please consider
+submitting your HDD info for inclusion into the Gentoo hddtemp
+database by filing a bug at https://bugs.gentoo.org/
+
+If hddtemp complains but finds your HDD temperature sensor, use the
+--quiet option to suppress the warning.
+"
+
src_prepare() {
epatch "${FILESDIR}"/${P}-satacmds.patch
epatch "${FILESDIR}"/${P}-byteswap.patch
@@ -57,6 +69,8 @@ src_install() {
systemd_newunit "${FILESDIR}"/hddtemp.service-r1 "${PN}.service"
systemd_install_serviced "${FILESDIR}"/hddtemp.service.conf
+ readme.gentoo_create_doc
+
if use network-cron; then
dosbin "${FILESDIR}"/update-hddtemp.db
exeinto /etc/cron.monthly
@@ -65,22 +79,6 @@ src_install() {
fi
}
-pkg_postinst() {
- elog "In order to update your hddtemp database, run:"
- if use network-cron; then
- elog " update-hddtemp.db"
- else
- elog " emerge --config =${CATEGORY}/${PF}"
- fi
- elog ""
- elog "If your hard drive is not recognized by hddtemp, please consider"
- elog "submitting your HDD info for inclusion into the Gentoo hddtemp"
- elog "database by filing a bug at https://bugs.gentoo.org/"
- echo
- ewarn "If hddtemp complains but finds your HDD temperature sensor, use the"
- ewarn "--quiet option to suppress the warning."
-}
-
update_db() {
local src=$1
local dst=$2
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild
index ff8c1bb49cc2..fee52f7ca17b 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild,v 1.9 2014/04/27 11:00:47 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r7.ebuild,v 1.10 2014/05/02 17:42:01 pacho Exp $
-inherit eutils autotools systemd
+EAPI=5
+inherit eutils autotools readme.gentoo systemd
MY_P=${P/_beta/-beta}
DBV=20080531
@@ -21,9 +22,19 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="In order to update your hddtemp database, run:
+emerge --config =${CATEGORY}/${PF}
+
+If your hard drive is not recognized by hddtemp, please consider
+submitting your HDD info for inclusion into the Gentoo hddtemp
+database by filing a bug at https://bugs.gentoo.org/
+
+If hddtemp complains but finds your HDD temperature sensor, use the
+--quiet option to suppress the warning.
+"
+
+src_prepare() {
epatch "${FILESDIR}"/${P}-satacmds.patch
epatch "${FILESDIR}"/${P}-byteswap.patch
epatch "${FILESDIR}"/${P}-execinfo.patch
@@ -33,18 +44,17 @@ src_unpack() {
AT_M4DIR="m4" eautoreconf
}
-src_compile() {
+src_configure() {
local myconf
myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
# disabling nls breaks compiling
use nls || myconf="--disable-nls ${myconf}"
- econf ${myconf} || die
- emake || die
+ econf ${myconf}
}
src_install() {
- make DESTDIR="${D}" install || die
+ default
dodoc README TODO ChangeLog
insinto /usr/share/hddtemp
@@ -56,18 +66,8 @@ src_install() {
newinitd "${FILESDIR}"/hddtemp-init hddtemp
systemd_newunit "${FILESDIR}"/hddtemp.service-r1 "${PN}.service"
systemd_install_serviced "${FILESDIR}"/hddtemp.service.conf
-}
-pkg_postinst() {
- elog "In order to update your hddtemp database, run:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog ""
- elog "If your hard drive is not recognized by hddtemp, please consider"
- elog "submitting your HDD info for inclusion into the Gentoo hddtemp"
- elog "database by filing a bug at https://bugs.gentoo.org/"
- echo
- ewarn "If hddtemp complains but finds your HDD temperature sensor, use the"
- ewarn "--quiet option to suppress the warning."
+ readme.gentoo_create_doc
}
update_db() {