summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-12-22 02:03:00 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-12-22 02:03:00 +0000
commitd7c9d094e6937ceb7a4a37d40fdf70ba150a2771 (patch)
tree6874904bf4af36adad74184ce1bf141a02274ec3 /app-admin/sshguard
parentMarking seamonkey-1.1.14 ppc for bug 251322 (diff)
downloadgentoo-2-d7c9d094e6937ceb7a4a37d40fdf70ba150a2771.tar.gz
gentoo-2-d7c9d094e6937ceb7a4a37d40fdf70ba150a2771.tar.bz2
gentoo-2-d7c9d094e6937ceb7a4a37d40fdf70ba150a2771.zip
1.3 version bump for bug 246823. Thanks to Priit Laes <amd at store20
dot com> (Portage version: 2.1.4.5)
Diffstat (limited to 'app-admin/sshguard')
-rw-r--r--app-admin/sshguard/ChangeLog8
-rw-r--r--app-admin/sshguard/sshguard-1.3.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/app-admin/sshguard/ChangeLog b/app-admin/sshguard/ChangeLog
index 39a2a0ea18a8..648bee8314ed 100644
--- a/app-admin/sshguard/ChangeLog
+++ b/app-admin/sshguard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/sshguard
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.8 2008/08/31 10:12:51 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/ChangeLog,v 1.9 2008/12/22 02:03:00 vanquirius Exp $
+
+*sshguard-1.3 (22 Dec 2008)
+
+ 22 Dec 2008; Marcelo Goes <vanquirius@gentoo.org> +sshguard-1.3.ebuild:
+ 1.3 version bump for bug 246823. Thanks to Priit Laes
+ <amd at store20 dot com>.
*sshguard-1.1 (31 Aug 2008)
diff --git a/app-admin/sshguard/sshguard-1.3.ebuild b/app-admin/sshguard/sshguard-1.3.ebuild
new file mode 100644
index 000000000000..0db5eca517e3
--- /dev/null
+++ b/app-admin/sshguard/sshguard-1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.3.ebuild,v 1.1 2008/12/22 02:03:00 vanquirius Exp $
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="ipfilter kernel_FreeBSD kernel_linux"
+
+DEPEND="kernel_linux? ( net-firewall/iptables )
+ kernel_FreeBSD? ( !ipfilter? ( sys-freebsd/freebsd-pf ) )"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_compile() {
+ local myconf
+ if use kernel_linux; then
+ myconf="--with-firewall=iptables"
+ elif use kernel_FreeBSD; then
+ use ipfilter && myconf="--with-firewall=ipfw" \
+ || myconf="--with-firewall=pf"
+ fi
+
+ econf ${myconf}
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README Changes || die "dodoc failed"
+ dodoc examples/* || die "dodoc failed"
+}