summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 01:43:54 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 01:43:54 +0000
commitee4bcf3e303f2aa9756e281d13062832afec743f (patch)
treea1fe442f2cab5c1b0726dae84463d82a9221eb80 /app-admin/system-config-bind
parentreverting keyword again (diff)
downloadgentoo-2-ee4bcf3e303f2aa9756e281d13062832afec743f.tar.gz
gentoo-2-ee4bcf3e303f2aa9756e281d13062832afec743f.tar.bz2
gentoo-2-ee4bcf3e303f2aa9756e281d13062832afec743f.zip
Bump.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-admin/system-config-bind')
-rw-r--r--app-admin/system-config-bind/ChangeLog10
-rw-r--r--app-admin/system-config-bind/files/digest-system-config-bind-4.0.23
-rw-r--r--app-admin/system-config-bind/system-config-bind-4.0.2.ebuild54
3 files changed, 65 insertions, 2 deletions
diff --git a/app-admin/system-config-bind/ChangeLog b/app-admin/system-config-bind/ChangeLog
index de4b96ab79e3..c1e542fd83ea 100644
--- a/app-admin/system-config-bind/ChangeLog
+++ b/app-admin/system-config-bind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/system-config-bind
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-bind/ChangeLog,v 1.2 2006/09/05 21:53:40 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-bind/ChangeLog,v 1.3 2007/07/15 01:43:54 dberkholz Exp $
+
+*system-config-bind-4.0.2 (15 Jul 2007)
+
+ 15 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +system-config-bind-4.0.2.ebuild:
+ Bump.
05 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
system-config-bind-4.0.0.ebuild:
diff --git a/app-admin/system-config-bind/files/digest-system-config-bind-4.0.2 b/app-admin/system-config-bind/files/digest-system-config-bind-4.0.2
new file mode 100644
index 000000000000..9692c6aea7fd
--- /dev/null
+++ b/app-admin/system-config-bind/files/digest-system-config-bind-4.0.2
@@ -0,0 +1,3 @@
+MD5 7b5c669e1d5e1751cd8e4b7225f8604d system-config-bind-4.0.2-8.fc8.src.rpm 9966436
+RMD160 10b7ccd398b86af6f53ab439646bcbdef5ec3e03 system-config-bind-4.0.2-8.fc8.src.rpm 9966436
+SHA256 b34ea73cdaffd282db5fe6b9ab93e7d649c3c8006f34fa2a57641579712dd0bb system-config-bind-4.0.2-8.fc8.src.rpm 9966436
diff --git a/app-admin/system-config-bind/system-config-bind-4.0.2.ebuild b/app-admin/system-config-bind/system-config-bind-4.0.2.ebuild
new file mode 100644
index 000000000000..10876c36ea9c
--- /dev/null
+++ b/app-admin/system-config-bind/system-config-bind-4.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-bind/system-config-bind-4.0.2.ebuild,v 1.1 2007/07/15 01:43:54 dberkholz Exp $
+
+inherit python eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="8"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="8"
+
+DESCRIPTION="The Red Hat BIND DNS Configuration Tool"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="=dev-python/pygtk-2*
+ dev-lang/python
+ =dev-python/gnome-python-2*
+ net-dns/bind
+ net-dns/bind-tools
+ net-dns/bind-dns-keygen
+ x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+
+ # by default it uses /etc/named.conf, not /etc/bind/named.conf
+ epatch "${FILESDIR}"/4.0.0-use-etc-bind-directory.patch
+}
+
+src_install() {
+ emake ROOT="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/{system-config-bind,bindconf}
+
+ # It assumes this file already exists. This is the equivalent
+ # of /etc/conf.d/named, so this is where arguments to named end up.
+ dodir /etc/sysconfig
+ touch "${D}"/etc/sysconfig/named
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}