summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-03-04 16:04:23 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-03-04 16:04:23 +0000
commit6626bcb5f48a3f8c3232ac8f5bbeaa17a3cdb12b (patch)
tree835d625b115b77720bedff18815a86c9b851b3f5 /app-admin/webapp-config
parentUnstable on hppa. (diff)
downloadgentoo-2-6626bcb5f48a3f8c3232ac8f5bbeaa17a3cdb12b.tar.gz
gentoo-2-6626bcb5f48a3f8c3232ac8f5bbeaa17a3cdb12b.tar.bz2
gentoo-2-6626bcb5f48a3f8c3232ac8f5bbeaa17a3cdb12b.zip
Added webapp-config-1.50.11 to the tree. Added a check for python>=2.4 to
both 1.50.* ebuilds. If the check fails, testing will be disabled. (Portage version: 2.0.54)
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/ChangeLog9
-rw-r--r--app-admin/webapp-config/Manifest4
-rw-r--r--app-admin/webapp-config/files/digest-webapp-config-1.50.111
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.10.ebuild15
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.11.ebuild57
5 files changed, 79 insertions, 7 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index bab289a1b31e..d4e1cb1c361b 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/webapp-config
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.23 2006/03/03 13:10:36 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.24 2006/03/04 16:04:23 wrobel Exp $
+
+*webapp-config-1.50.11 (04 Mar 2006)
+
+ 04 Mar 2006; <wrobel@gentoo.org> webapp-config-1.50.10.ebuild,
+ +webapp-config-1.50.11.ebuild:
+ Added webapp-config-1.50.11 to the tree. Added a check for python>=2.4 to
+ both 1.50.* ebuilds. If the check fails, testing will be disabled.
03 Mar 2006; Jose Luis Rivero <yoswink@gentoo.org>
webapp-config-1.50.10.ebuild:
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index b1debc8b81b9..9aef3e08c28c 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,6 +1,8 @@
MD5 68279c7055a5783844515b9a39496927 ChangeLog 17112
MD5 6aad9c4cd4548cb948cd4035286d6ac7 files/digest-webapp-config-1.11 70
MD5 4a197b74bf68a2f921f202710177d4a6 files/digest-webapp-config-1.50.10 72
+MD5 4fe01602d20cd4c4486f83949e332dd9 files/digest-webapp-config-1.50.11 72
MD5 4defd726d2b03decc5b7ff21b0aac1a3 metadata.xml 225
MD5 90bba75c31e392fd21e084681aeca6ae webapp-config-1.11.ebuild 1408
-MD5 6a6716cd2019701c40c129c8d4d229b3 webapp-config-1.50.10.ebuild 1677
+MD5 128eb745b3214043aa7916476fcefe70 webapp-config-1.50.10.ebuild 1831
+MD5 83dcead065ae8986c41a350ceace8c1c webapp-config-1.50.11.ebuild 1834
diff --git a/app-admin/webapp-config/files/digest-webapp-config-1.50.11 b/app-admin/webapp-config/files/digest-webapp-config-1.50.11
new file mode 100644
index 000000000000..e18428b230e2
--- /dev/null
+++ b/app-admin/webapp-config/files/digest-webapp-config-1.50.11
@@ -0,0 +1 @@
+MD5 9b225128a5813beb638501ff86e9a9db webapp-config-1.50.11.tar.gz 93949
diff --git a/app-admin/webapp-config/webapp-config-1.50.10.ebuild b/app-admin/webapp-config/webapp-config-1.50.10.ebuild
index 63f8e81c3608..852abc4a77c8 100644
--- a/app-admin/webapp-config/webapp-config-1.50.10.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.10.ebuild,v 1.7 2006/03/03 13:10:36 yoswink Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.10.ebuild,v 1.8 2006/03/04 16:04:23 wrobel Exp $
inherit eutils distutils
@@ -35,10 +35,15 @@ src_install() {
src_test() {
cd ${S}
- einfo "Running webapp-config doctests..."
- if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
- eerror "DocTests failed - please submit a bug report"
- die "DocTesting failed!"
+ distutils_python_version
+ if [[ $PYVER_MAJOR > 1 ]] && [[ $PYVER_MINOR > 3 ]] ; then
+ einfo "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ einfo "Python version below 2.4! Disabling tests."
fi
}
diff --git a/app-admin/webapp-config/webapp-config-1.50.11.ebuild b/app-admin/webapp-config/webapp-config-1.50.11.ebuild
new file mode 100644
index 000000000000..003f6ca5fbc2
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.11.ebuild,v 1.1 2006/03/04 16:04:23 wrobel Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~wrobel/webapp-config/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ distutils_python_version
+ if [[ $PYVER_MAJOR > 1 ]] && [[ $PYVER_MINOR > 3 ]] ; then
+ einfo "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+ else
+ einfo "Python version below 2.4! Disabling tests."
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ epause 5
+}