summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAJ Lewis <roadrunner@gentoo.org>2001-06-28 14:27:19 +0000
committerAJ Lewis <roadrunner@gentoo.org>2001-06-28 14:27:19 +0000
commite994fd98ca8836c67777354d76954d6984d6f7ac (patch)
tree47ece40ede2b3705760fc409ef5963f7b4243c65 /app-admin/whowatch
parentGabber - A Jabber Client Gnome (diff)
downloadgentoo-2-e994fd98ca8836c67777354d76954d6984d6f7ac.tar.gz
gentoo-2-e994fd98ca8836c67777354d76954d6984d6f7ac.tar.bz2
gentoo-2-e994fd98ca8836c67777354d76954d6984d6f7ac.zip
o an interactive who-like program
Diffstat (limited to 'app-admin/whowatch')
-rw-r--r--app-admin/whowatch/files/digest-whowatch-1.5.21
-rw-r--r--app-admin/whowatch/files/whowatch-1.5.2-gentoo.diff13
-rw-r--r--app-admin/whowatch/whowatch-1.5.2.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/whowatch/files/digest-whowatch-1.5.2 b/app-admin/whowatch/files/digest-whowatch-1.5.2
new file mode 100644
index 000000000000..e5e69f89eae9
--- /dev/null
+++ b/app-admin/whowatch/files/digest-whowatch-1.5.2
@@ -0,0 +1 @@
+MD5 95ad3ea12b1c33e59e93c9a1ab1812d3 whowatch-1.5.2.tar.gz
diff --git a/app-admin/whowatch/files/whowatch-1.5.2-gentoo.diff b/app-admin/whowatch/files/whowatch-1.5.2-gentoo.diff
new file mode 100644
index 000000000000..0bb0a8689463
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.5.2-gentoo.diff
@@ -0,0 +1,13 @@
+diff -Nur whowatch-1.5.2/Makefile.in whowatch-1.5.2-new/Makefile.in
+--- whowatch-1.5.2/Makefile.in Sun Mar 11 15:04:41 2001
++++ whowatch-1.5.2-new/Makefile.in Thu Jun 28 09:09:27 2001
+@@ -70,7 +70,9 @@
+ rm -rf ./*.o
+ rm -f whowatch
+ install: whowatch
++ $(INSTALL) -d $(bindir)
+ $(INSTALL) -m 755 whowatch $(bindir)/whowatch
++ $(INSTALL) -d $(mandir)/man1
+ $(INSTALL) -m 644 whowatch.1 $(mandir)/man1/whowatch.1
+
+ distclean:
diff --git a/app-admin/whowatch/whowatch-1.5.2.ebuild b/app-admin/whowatch/whowatch-1.5.2.ebuild
new file mode 100644
index 000000000000..ac04efd9e9c6
--- /dev/null
+++ b/app-admin/whowatch/whowatch-1.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author AJ Lewis <aj@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/whowatch/whowatch-1.5.2.ebuild,v 1.1 2001/06/28 14:27:19 roadrunner Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="an interactive who-like program that displays information
+about the users currently logged on to the machine, in real time."
+SRC_URI="http://wizard.ae.krakow.pl/~mike/download/${A}"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ try patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr mandir=${DIR}/usr/share/man install
+
+}
+