summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-04-03 10:24:04 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-04-03 10:24:04 +0000
commit10e46269c04c32d6e43215901159e16495d3e688 (patch)
tree861b674a4717bb9b08733c882c5688611274a169 /app-admin
parentFixed dependencies to pull in higher version. (diff)
downloadgentoo-2-10e46269c04c32d6e43215901159e16495d3e688.tar.gz
gentoo-2-10e46269c04c32d6e43215901159e16495d3e688.tar.bz2
gentoo-2-10e46269c04c32d6e43215901159e16495d3e688.zip
fix #213436
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog7
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild11
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild64
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild3
4 files changed, 13 insertions, 72 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 276651c431f5..a8a12a393e8c 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/webapp-config
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.62 2008/02/17 18:06:02 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.63 2008/04/03 10:24:04 hollow Exp $
+
+ 03 Apr 2008; Benedikt Böhm <hollow@gentoo.org>
+ webapp-config-1.50.16-r1.ebuild, -webapp-config-1.50.16-r2.ebuild,
+ webapp-config-1.50.16-r3.ebuild:
+ fix #213436
*webapp-config-1.50.16-r3 (17 Feb 2008)
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
index f1b8d7829ec4..26e37bddfd15 100644
--- a/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild,v 1.10 2007/08/25 11:44:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r1.ebuild,v 1.11 2008/04/03 10:24:04 hollow Exp $
inherit eutils distutils
@@ -31,16 +31,15 @@ src_install() {
distutils_src_install --install-scripts="/usr/sbin"
dodir /etc/vhosts
- cp config/webapp-config ${D}/etc/vhosts/
+ cp config/webapp-config "${D}"/etc/vhosts/
keepdir /usr/share/webapps
keepdir /var/db/webapps
dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
- doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
- dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+ doman doc/webapp-config.5 doc/webapp-config.8
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html
}
src_test() {
- cd ${S}
distutils_python_version
if [[ $PYVER_MAJOR -gt 1 ]] && [[ $PYVER_MINOR -gt 3 ]] ; then
elog "Running webapp-config doctests..."
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild
deleted file mode 100644
index 4bd529fdb9f8..000000000000
--- a/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r2.ebuild,v 1.1 2007/09/09 21:11:40 hollow Exp $
-
-inherit eutils distutils
-
-DESCRIPTION="Gentoo's installer for web-based applications"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI="http://build.pardus.de/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-apache-move.patch
- epatch "${FILESDIR}"/${P}-baselayout2.patch
-}
-
-src_install() {
-
- # According to this discussion:
- # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
- # distutils does not provide for specifying two different script install
- # locations. Since we only install one script here the following should
- # be ok
- distutils_src_install --install-scripts="/usr/sbin"
-
- dodir /etc/vhosts
- cp config/webapp-config ${D}/etc/vhosts/
- keepdir /usr/share/webapps
- keepdir /var/db/webapps
- dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
- doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
- dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
-}
-
-src_test() {
- cd ${S}
- distutils_python_version
- if [[ $PYVER_MAJOR -gt 1 ]] && [[ $PYVER_MINOR -gt 3 ]] ; then
- elog "Running webapp-config doctests..."
- if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
- eerror "DocTests failed - please submit a bug report"
- die "DocTesting failed!"
- fi
- else
- elog "Python version below 2.4! Disabling tests."
- fi
-}
-
-pkg_postinst() {
- echo
- elog "Now that you have upgraded webapp-config, you **must** update your"
- elog "config files in /etc/vhosts/webapp-config before you emerge any"
- elog "packages that use webapp-config."
- echo
- epause 5
-}
diff --git a/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild b/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
index 12eb57b92aa7..341727325b79 100644
--- a/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild,v 1.1 2008/02/17 18:06:02 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.16-r3.ebuild,v 1.2 2008/04/03 10:24:04 hollow Exp $
inherit eutils distutils
@@ -22,6 +22,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-baselayout2.patch
epatch "${FILESDIR}"/${P}-htdocs-symlink.patch
epatch "${FILESDIR}"/${P}-absolute-paths.patch
+ rm -f doc/webapp.eclass.5{,.html}
}
src_install() {