summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-12-29 09:15:08 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-12-29 09:15:08 +0000
commit4290e93b3e6d9059a9b33af372016aca90cf4ce2 (patch)
treee40c24e3a41ea0ae827be6a23c08828e53e667f8 /app-admin
parentia64 stable wrt bug #487870 (diff)
downloadgentoo-2-4290e93b3e6d9059a9b33af372016aca90cf4ce2.tar.gz
gentoo-2-4290e93b3e6d9059a9b33af372016aca90cf4ce2.tar.bz2
gentoo-2-4290e93b3e6d9059a9b33af372016aca90cf4ce2.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/ChangeLog7
-rw-r--r--app-admin/ansible/ansible-1.4.3.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/app-admin/ansible/ChangeLog b/app-admin/ansible/ChangeLog
index 457a042323d4..5905160cc132 100644
--- a/app-admin/ansible/ChangeLog
+++ b/app-admin/ansible/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/ansible
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.30 2013/12/09 18:53:34 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ChangeLog,v 1.31 2013/12/29 09:15:08 pinkbyte Exp $
+
+*ansible-1.4.3 (29 Dec 2013)
+
+ 29 Dec 2013; Sergey Popov <pinkbyte@gentoo.org> +ansible-1.4.3.ebuild:
+ Version bump
09 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
+files/tests-ansible-1.4.1.patch, ansible-1.4.1.ebuild:
diff --git a/app-admin/ansible/ansible-1.4.3.ebuild b/app-admin/ansible/ansible-1.4.3.ebuild
new file mode 100644
index 000000000000..a659e63e2979
--- /dev/null
+++ b/app-admin/ansible/ansible-1.4.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ansible/ansible-1.4.3.ebuild,v 1.1 2013/12/29 09:15:08 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
+HOMEPAGE="http://ansible.cc/"
+SRC_URI="https://github.com/ansible/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/nose
+ dev-vcs/git
+ )"
+RDEPEND="
+ dev-python/jinja
+ dev-python/pyyaml
+ dev-python/paramiko
+ net-misc/sshpass
+ virtual/ssh
+"
+
+DOC_CONTENTS="You can define parameters through shell variables OR use config files
+Examples of config files installed in /usr/share/doc/${PF}/examples\n\n
+You have to create ansible hosts file!\n
+More info on http://ansible.cc/docs/gettingstarted.html"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # Skip tests which need ssh access
+ sed -i 's:$(NOSETESTS) -d -v:\0 -e \\(TestPlayBook.py\\|TestRunner.py\\):' Makefile || die "sed failed"
+}
+
+python_test() {
+ make tests || die "tests failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman docs/man/man1/*.1
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ # Hint: do not install example config files into /etc
+ # let this choice to user
+
+ newenvd "${FILESDIR}"/${PN}.env 95ansible
+}
+
+src_install() {
+ distutils-r1_src_install
+ readme.gentoo_create_doc
+}