summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-21 08:32:51 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-21 08:32:51 +0000
commitb6b8c8ae6deb36955db2e02bfe6ab25ef51da9ac (patch)
tree7724aa4c22bc0d2fab97aaf70d5d7950bdd28e28 /app-admin
parentapp-misc/wcd: Version Bump (diff)
downloadgentoo-2-b6b8c8ae6deb36955db2e02bfe6ab25ef51da9ac.tar.gz
gentoo-2-b6b8c8ae6deb36955db2e02bfe6ab25ef51da9ac.tar.bz2
gentoo-2-b6b8c8ae6deb36955db2e02bfe6ab25ef51da9ac.zip
Clean up broken symlinks and empty directories. Complain about custom xorg.conf.d files as well.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-opengl/ChangeLog9
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.3.1-r2.ebuild (renamed from app-admin/eselect-opengl/eselect-opengl-1.3.1-r1.ebuild)27
2 files changed, 26 insertions, 10 deletions
diff --git a/app-admin/eselect-opengl/ChangeLog b/app-admin/eselect-opengl/ChangeLog
index ef687edb21b1..bc4d006e46ca 100644
--- a/app-admin/eselect-opengl/ChangeLog
+++ b/app-admin/eselect-opengl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/eselect-opengl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.136 2015/01/03 23:34:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.137 2015/01/21 08:32:51 mgorny Exp $
+
+*eselect-opengl-1.3.1-r2 (21 Jan 2015)
+
+ 21 Jan 2015; Michał Górny <mgorny@gentoo.org> +eselect-opengl-1.3.1-r2.ebuild,
+ -eselect-opengl-1.3.1-r1.ebuild:
+ Clean up broken symlinks and empty directories. Complain about custom
+ xorg.conf.d files as well.
03 Jan 2015; Michał Górny <mgorny@gentoo.org> eselect-opengl-1.3.1-r1.ebuild:
Complain about Files section until we find a more permanent solution.
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.3.1-r1.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.3.1-r2.ebuild
index 7deb62e3dce6..e4ba889a02cf 100644
--- a/app-admin/eselect-opengl/eselect-opengl-1.3.1-r1.ebuild
+++ b/app-admin/eselect-opengl/eselect-opengl-1.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.3.1-r1.ebuild,v 1.2 2015/01/03 23:34:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.3.1-r2.ebuild,v 1.1 2015/01/21 08:32:51 mgorny Exp $
EAPI=5
@@ -37,14 +37,18 @@ RDEPEND=">=app-admin/eselect-1.2.4
S=${WORKDIR}
pkg_pretend() {
- if grep -q -s "Section.*Files" \
- "${EROOT%/}"/etc/X11/xorg.conf
- then
- ewarn 'Your /etc/X11/xorg.conf seems to contain Section "Files". This is'
- ewarn 'known to break eselect-opengl-1.3*. If you need a custom Files setup,'
- ewarn 'please downgrade to <eselect-opengl-1.3. We are sorry for the issues,'
- ewarn 'we are working on a more permanent solution.'
- fi
+ local f
+ for f in "${EROOT%/}"/etc/X11/xorg.conf{,.d/*}; do
+ if [[ ${f} != *20opengl.conf ]]; then
+ if grep -q -r -s "Section.*Files" "${f}"
+ then
+ ewarn "Your ${f} file seems to contain Section 'Files'. This is known to break"
+ ewarn 'eselect-opengl-1.3*. If you need a custom Files setup, please downgrade'
+ ewarn 'to <eselect-opengl-1.3. We are sorry for the issues, we are working'
+ ewarn 'on a more permanent solution.'
+ fi
+ fi
+ done
}
pkg_preinst() {
@@ -53,6 +57,11 @@ pkg_preinst() {
}
pkg_postinst() {
+ # delete broken symlinks
+ find "${EROOT}"/usr/lib*/opengl -xtype l -delete
+ # delete empty leftover directories (they confuse eselect)
+ find "${EROOT}"/usr/lib*/opengl -depth -type d -empty -exec rmdir -v {} +
+
if [[ -n "${OLD_IMPL}" && "${OLD_IMPL}" != '(none)' ]] ; then
eselect opengl set "${OLD_IMPL}"
fi