summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-27 21:51:34 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-27 21:51:34 +0000
commit44d77f0df74922eadb4e75bff69a1818a6a413e2 (patch)
tree7990c7d64bc4813beabdf91b5bddac354c794b4e /app-antivirus/klamav/klamav-0.42.ebuild
parent * bump to 1.3.3 and clean up old revisions (diff)
downloadgentoo-2-44d77f0df74922eadb4e75bff69a1818a6a413e2.tar.gz
gentoo-2-44d77f0df74922eadb4e75bff69a1818a6a413e2.tar.bz2
gentoo-2-44d77f0df74922eadb4e75bff69a1818a6a413e2.zip
Version bump. We disable the updates from the GUI as we have package managers for that. cf. bug 171414.
(Portage version: 2.1.4)
Diffstat (limited to 'app-antivirus/klamav/klamav-0.42.ebuild')
-rw-r--r--app-antivirus/klamav/klamav-0.42.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-antivirus/klamav/klamav-0.42.ebuild b/app-antivirus/klamav/klamav-0.42.ebuild
new file mode 100644
index 000000000000..87bdab26079e
--- /dev/null
+++ b/app-antivirus/klamav/klamav-0.42.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.42.ebuild,v 1.1 2008/01/27 21:51:33 philantrop Exp $
+
+inherit kde
+
+MY_P="${P}-source"
+S="${WORKDIR}/${MY_P}/${P}"
+
+DESCRIPTION="KlamAV is a KDE frontend for the ClamAV antivirus."
+HOMEPAGE="http://klamav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-antivirus/clamav-0.90"
+RDEPEND="${DEPEND}"
+
+need-kde 3.5
+
+PATCHES="${FILESDIR}/${PN}-0.41-cl_loaddbdir.patch"
+
+src_unpack(){
+ kde_src_unpack
+
+ # Disable updates from the GUI. We have package managers for that. cf. bug 171414
+ econf --with-disableupdates
+
+ # Assure a future version won't try to build this.
+ rm -rf "${WORKDIR}/${MY_P}/dazuko"* || die "We missed to eradicate some files"
+
+ rm -f "${S}"/configure
+}
+
+pkg_postinst(){
+ elog "The on-access scanning functionality is provided by"
+ elog "the Dazuko kernel module: emerge sys-fs/dazuko"
+}