summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-09-06 15:19:42 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-09-06 15:19:42 +0000
commit38f2ab0b17888f28b8b524e82b23bcca04711c77 (patch)
treedd35f7afb8730f7aa0ffadbafe5a0004ccca0ac9 /app-antivirus/klamav
parentx86 stable wrt #236389 (diff)
downloadgentoo-2-38f2ab0b17888f28b8b524e82b23bcca04711c77.tar.gz
gentoo-2-38f2ab0b17888f28b8b524e82b23bcca04711c77.tar.bz2
gentoo-2-38f2ab0b17888f28b8b524e82b23bcca04711c77.zip
Fix compilation error with >=clamav-0.94, bug #236838
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'app-antivirus/klamav')
-rw-r--r--app-antivirus/klamav/ChangeLog6
-rw-r--r--app-antivirus/klamav/files/klamav-clamav094.patch14
-rw-r--r--app-antivirus/klamav/klamav-0.42.ebuild7
-rw-r--r--app-antivirus/klamav/klamav-0.44.ebuild7
4 files changed, 31 insertions, 3 deletions
diff --git a/app-antivirus/klamav/ChangeLog b/app-antivirus/klamav/ChangeLog
index 3b4b88c47e67..2677462a2eaf 100644
--- a/app-antivirus/klamav/ChangeLog
+++ b/app-antivirus/klamav/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-antivirus/klamav
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/ChangeLog,v 1.47 2008/08/22 18:40:00 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/ChangeLog,v 1.48 2008/09/06 15:19:41 keytoaster Exp $
+
+ 06 Sep 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +files/klamav-clamav094.patch, klamav-0.42.ebuild, klamav-0.44.ebuild:
+ Fix compilation error with >=clamav-0.94, bug #236838
*klamav-0.44 (22 Aug 2008)
diff --git a/app-antivirus/klamav/files/klamav-clamav094.patch b/app-antivirus/klamav/files/klamav-clamav094.patch
new file mode 100644
index 000000000000..5131cf911375
--- /dev/null
+++ b/app-antivirus/klamav/files/klamav-clamav094.patch
@@ -0,0 +1,14 @@
+diff -ur klamav-0.44/src/klammail/clamdmail.c klamav-0.44-clamav094/src/klammail/clamdmail.c
+--- klamav-0.44/src/klammail/clamdmail.c 2008-07-06 14:05:39.000000000 +0200
++++ klamav-0.44-clamav094/src/klammail/clamdmail.c 2008-09-06 13:51:46.000000000 +0200
+@@ -160,7 +160,8 @@
+ if(fsync(fd) == -1) {
+ // cli_dbgmsg("fsync() failed for descriptor %d\n", fd);
+ close(fd);
+- return CL_EFSYNC;
++// return CL_EFSYNC;
++ return CL_EIO;
+ }
+
+ close(fd);
+
diff --git a/app-antivirus/klamav/klamav-0.42.ebuild b/app-antivirus/klamav/klamav-0.42.ebuild
index dc50538bae4a..0021688202ba 100644
--- a/app-antivirus/klamav/klamav-0.42.ebuild
+++ b/app-antivirus/klamav/klamav-0.42.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.42.ebuild,v 1.8 2008/04/25 22:48:51 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.42.ebuild,v 1.9 2008/09/06 15:19:41 keytoaster Exp $
inherit kde
@@ -31,6 +31,11 @@ src_unpack(){
epatch "${FILESDIR}/${P}-clamav093.patch"
fi
+ # Fix compiliaton error with >=clamav-0.94, bug #236838
+ if has_version '>=app-antivirus/clamav-0.94' ; then
+ epatch "${FILESDIR}/klamav-clamav094.patch"
+ fi
+
# Assure a future version won't try to build this.
rm -rf "${WORKDIR}/${MY_P}/dazuko"* || die "We missed to eradicate some files"
diff --git a/app-antivirus/klamav/klamav-0.44.ebuild b/app-antivirus/klamav/klamav-0.44.ebuild
index e3f8396ee6fd..685f151ecf30 100644
--- a/app-antivirus/klamav/klamav-0.44.ebuild
+++ b/app-antivirus/klamav/klamav-0.44.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.44.ebuild,v 1.1 2008/08/22 18:40:00 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/klamav/klamav-0.44.ebuild,v 1.2 2008/09/06 15:19:41 keytoaster Exp $
ARTS_REQUIRED="never"
@@ -29,6 +29,11 @@ src_unpack(){
# Fix .desktop entry.
epatch "${FILESDIR}/klamav-0.43-desktop-entry.diff"
+ # Fix compiliaton error with >=clamav-0.94, bug #236838
+ if has_version '>=app-antivirus/clamav-0.94' ; then
+ epatch "${FILESDIR}/klamav-clamav094.patch"
+ fi
+
# Assure a future version won't try to build this.
rm -rf "${WORKDIR}/${MY_P}/dazuko"* || die "We missed to eradicate some files"