summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-05-30 00:28:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-05-30 00:28:39 +0000
commit4b3a968990e214855be173add437d87509803487 (patch)
treebce38405b4202811b549c1291d546bbacd9f76af /app-antivirus/vlnx/vlnx-414e-r2.ebuild
parentmove net-mail/f-prot app-antivirus/f-prot (Manifest recommit) (diff)
downloadgentoo-2-4b3a968990e214855be173add437d87509803487.tar.gz
gentoo-2-4b3a968990e214855be173add437d87509803487.tar.bz2
gentoo-2-4b3a968990e214855be173add437d87509803487.zip
move net-mail/vlnx app-antivirus/vlnx
Diffstat (limited to 'app-antivirus/vlnx/vlnx-414e-r2.ebuild')
-rw-r--r--app-antivirus/vlnx/vlnx-414e-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-antivirus/vlnx/vlnx-414e-r2.ebuild b/app-antivirus/vlnx/vlnx-414e-r2.ebuild
new file mode 100644
index 000000000000..13abceb621e2
--- /dev/null
+++ b/app-antivirus/vlnx/vlnx-414e-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Script Revised by Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/vlnx/vlnx-414e-r2.ebuild,v 1.1 2004/05/30 00:28:39 robbat2 Exp $
+
+MY_P=${PN}${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="McAfee VirusScanner for Unix/Linux(Shareware)"
+SRC_URI="http://download.nai.com/products/evaluation/virusscan/english/cmdline/linux/version_4.14/${MY_P}.tar.Z
+ http://download.nai.com/products/datfiles/4.x/nai/dat-4240.tar"
+HOMEPAGE="http://www.mcafeeb2b.com/"
+
+SLOT="0"
+LICENSE="VirusScan"
+KEYWORDS="-* x86"
+RESTRICT="nostrip"
+
+DEPEND=""
+RDEPEND=""
+PROVIDE="virtual/antivirus"
+
+src_unpack() {
+ cd ${WORKDIR}
+ mkdir ${MY_P}
+ cd ${MY_P}
+ unpack vlnx414e.tar.Z
+ tar -xf ${DISTDIR}/dat-4240.tar
+}
+
+src_install() {
+ dodir /usr/bin
+ insinto /opt/vlnx
+
+ doins liblnxfv.so
+ doins uvscan
+ doins *.dat
+ dodoc *.txt *.pdf
+ doman uvscan.1
+ chmod 755 ${D}/opt/vlnx/uvscan
+
+ dodir /etc/env.d
+ cp -f ${FILESDIR}/vlnx-${PV}-envd ${D}/etc/env.d/40vlnx
+}