summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 20:12:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 20:12:20 +0000
commit0de7a79a4d9e625f0c5a87a88688692c463165fe (patch)
tree752ca0115b72cb09f05dca3d7c2b08dcc000cafa /app-arch/cabextract
parentTweak the configure logic. (diff)
downloadgentoo-2-0de7a79a4d9e625f0c5a87a88688692c463165fe.tar.gz
gentoo-2-0de7a79a4d9e625f0c5a87a88688692c463165fe.tar.bz2
gentoo-2-0de7a79a4d9e625f0c5a87a88688692c463165fe.zip
Add patch to fix mempcpy check unconditionally. Mark ~x86-fbsd.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'app-arch/cabextract')
-rw-r--r--app-arch/cabextract/ChangeLog6
-rw-r--r--app-arch/cabextract/cabextract-1.1.ebuild10
-rw-r--r--app-arch/cabextract/files/cabextract-1.1-mempcpy.patch12
3 files changed, 22 insertions, 6 deletions
diff --git a/app-arch/cabextract/ChangeLog b/app-arch/cabextract/ChangeLog
index 06901008b990..3e429c741c54 100644
--- a/app-arch/cabextract/ChangeLog
+++ b/app-arch/cabextract/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/cabextract
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/ChangeLog,v 1.30 2006/01/05 11:41:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/ChangeLog,v 1.31 2006/04/18 20:12:20 flameeyes Exp $
+
+ 18 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/cabextract-1.1-mempcpy.patch, cabextract-1.1.ebuild:
+ Add patch to fix mempcpy check unconditionally. Mark ~x86-fbsd.
05 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> cabextract-1.1.ebuild:
Don't apply the -configure patch conditional to userland, and as FreeBSD
diff --git a/app-arch/cabextract/cabextract-1.1.ebuild b/app-arch/cabextract/cabextract-1.1.ebuild
index 3b171374fb29..80e694ae5405 100644
--- a/app-arch/cabextract/cabextract-1.1.ebuild
+++ b/app-arch/cabextract/cabextract-1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.1.ebuild,v 1.13 2006/01/05 11:41:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cabextract/cabextract-1.1.ebuild,v 1.14 2006/04/18 20:12:20 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Extracts files from Microsoft .cab files"
HOMEPAGE="http://www.kyz.uklinux.net/cabextract.php"
@@ -10,7 +10,7 @@ SRC_URI="http://www.kyz.uklinux.net/downloads/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86 ppc-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc-macos ppc64 s390 sparc x86 ~x86-fbsd"
IUSE=""
DEPEND="virtual/libc"
@@ -18,8 +18,8 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
- [[ ${ELIBC} == "Darwin" ]] && \
- epatch ${FILESDIR}/${PN}-configure.patch
+ epatch "${FILESDIR}/${P}-mempcpy.patch"
+ eautoreconf
}
src_install() {
diff --git a/app-arch/cabextract/files/cabextract-1.1-mempcpy.patch b/app-arch/cabextract/files/cabextract-1.1-mempcpy.patch
new file mode 100644
index 000000000000..3ff0d20eacb9
--- /dev/null
+++ b/app-arch/cabextract/files/cabextract-1.1-mempcpy.patch
@@ -0,0 +1,12 @@
+Index: cabextract-1.1/configure.ac
+===================================================================
+--- cabextract-1.1.orig/configure.ac
++++ cabextract-1.1/configure.ac
+@@ -37,7 +37,6 @@ AC_CHECK_FUNCS([memcpy strcasecmp strchr
+ AC_CHECK_FUNCS([getopt_long],,[AC_CHECK_LIB([gnugetopt], [getopt_long],
+ [AC_DEFINE([HAVE_GETOPT_LONG])],[AC_LIBOBJ(getopt) AC_LIBOBJ(getopt1)])])
+ AC_REPLACE_FNMATCH
+-AC_REPLACE_FUNCS([mempcpy])
+
+ AC_CONFIG_FILES([Makefile cabextract.spec])
+ AC_OUTPUT