summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-09-16 16:13:35 +0000
committerMarinus Schraal <foser@gentoo.org>2004-09-16 16:13:35 +0000
commit939bcfb60d7d25235b333a8f9b8b4ff31f318835 (patch)
tree181f5c5c71be544a2d57b2450bee31329cda5a22 /app-arch/file-roller
parentRevision bump for security bug #63551. Added ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-939bcfb60d7d25235b333a8f9b8b4ff31f318835.tar.gz
gentoo-2-939bcfb60d7d25235b333a8f9b8b4ff31f318835.tar.bz2
gentoo-2-939bcfb60d7d25235b333a8f9b8b4ff31f318835.zip
gnome 2.8 release
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/ChangeLog8
-rw-r--r--app-arch/file-roller/Manifest2
-rw-r--r--app-arch/file-roller/file-roller-2.8.0.ebuild49
-rw-r--r--app-arch/file-roller/files/digest-file-roller-2.8.01
-rw-r--r--app-arch/file-roller/files/file-roller-2.8.0-use_bin_tar.patch11
5 files changed, 70 insertions, 1 deletions
diff --git a/app-arch/file-roller/ChangeLog b/app-arch/file-roller/ChangeLog
index 24e88f446cfd..ac57253e9575 100644
--- a/app-arch/file-roller/ChangeLog
+++ b/app-arch/file-roller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/file-roller
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.80 2004/09/13 08:30:15 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.81 2004/09/16 16:13:35 foser Exp $
+
+*file-roller-2.8.0 (16 Sep 2004)
+
+ 16 Sep 2004; foser <foser@gentoo.org> file-roller-2.8.0.ebuild :
+ Gnome 2.8 release
+ Update patches
*file-roller-2.6.2 (13 Sep 2004)
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index a72d95d85069..c6a8e6d24132 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,4 +1,5 @@
MD5 a5ffac070668eb553f3e3b1b7266c302 file-roller-2.6.2.ebuild 1224
+MD5 95a73b5053ace8961d9a4d063d57db9d file-roller-2.8.0.ebuild 1207
MD5 54499cabe95659969086224dc308381c file-roller-2.6.1.ebuild 1206
MD5 3db60db955c065e4d8fd4560080f661b file-roller-2.4.4-r2.ebuild 1071
MD5 b068979a95a33018cdda757f010ccea3 file-roller-2.6.0.ebuild 1206
@@ -12,4 +13,5 @@ MD5 7c3bf595636ee254e23445ccf07c4075 files/file-roller-2.4.4-64bit.patch 2808
MD5 9a6c274d4965d6aa2e83abe0e57133b1 files/digest-file-roller-2.6.0 71
MD5 a2afcaf32ad39410e36d24188021895e files/digest-file-roller-2.6.1 71
MD5 a2d30ce698b5120d01da4d3593bbf2c2 files/digest-file-roller-2.6.2 71
+MD5 519fed8816b9e6198b4cd9f6cdf9e525 files/digest-file-roller-2.8.0 71
MD5 07fa4739c733d5e4453bfb797cf6a279 files/digest-file-roller-2.4.4-r2 70
diff --git a/app-arch/file-roller/file-roller-2.8.0.ebuild b/app-arch/file-roller/file-roller-2.8.0.ebuild
new file mode 100644
index 000000000000..28c4940c3bd0
--- /dev/null
+++ b/app-arch/file-roller/file-roller-2.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.8.0.ebuild,v 1.1 2004/09/16 16:13:35 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.4*
+ >=gnome-base/libgnome-2.1
+ >=gnome-base/libgnomeui-2.1
+ >=gnome-base/gnome-vfs-2.2
+ >=gnome-base/libglade-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.3.11"
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README TODO"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch ${FILESDIR}/${P}-use_bin_tar.patch
+ # use a local rpm2cpio script to avoid the dep
+ epatch ${FILESDIR}/${PN}-2.6-use_fr_rpm2cpio.patch
+
+}
+
+src_install() {
+
+ gnome2_src_install
+ dobin ${FILESDIR}/rpm2cpio-file-roller
+
+}
diff --git a/app-arch/file-roller/files/digest-file-roller-2.8.0 b/app-arch/file-roller/files/digest-file-roller-2.8.0
new file mode 100644
index 000000000000..60d48e6a2c99
--- /dev/null
+++ b/app-arch/file-roller/files/digest-file-roller-2.8.0
@@ -0,0 +1 @@
+MD5 4a26cdecb3e2ed0f94e34ef5995fa890 file-roller-2.8.0.tar.bz2 1376414
diff --git a/app-arch/file-roller/files/file-roller-2.8.0-use_bin_tar.patch b/app-arch/file-roller/files/file-roller-2.8.0-use_bin_tar.patch
new file mode 100644
index 000000000000..ebc193576ded
--- /dev/null
+++ b/app-arch/file-roller/files/file-roller-2.8.0-use_bin_tar.patch
@@ -0,0 +1,11 @@
+--- src/fr-command-tar.c 2004-09-13 19:48:16.000000000 +0200
++++ src/fr-command-tar.c.patched 2004-09-16 18:04:07.080792848 +0200
+@@ -338,7 +338,7 @@
+ if (path != NULL)
+ fr_process_begin_command (comm->process, path);
+ else
+- fr_process_begin_command (comm->process, "tar");
++ fr_process_begin_command (comm->process, "/bin/tar");
+
+ temp = g_strdup_printf ("PATH=%s", prev_path);
+ putenv (temp);