summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-04-04 13:50:50 +0000
committerMarinus Schraal <foser@gentoo.org>2006-04-04 13:50:50 +0000
commitd1e5efa4a97a31dd2901e2258f205b7ce6a631ce (patch)
treea3f90ab25da28971940b2402210c7911f080b55c /app-arch/file-roller
parentAdd kaffeine with a fix for HTTP input. (diff)
downloadgentoo-2-d1e5efa4a97a31dd2901e2258f205b7ce6a631ce.tar.gz
gentoo-2-d1e5efa4a97a31dd2901e2258f205b7ce6a631ce.tar.bz2
gentoo-2-d1e5efa4a97a31dd2901e2258f205b7ce6a631ce.zip
fix crasher and dnd behaviour
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/ChangeLog6
-rw-r--r--app-arch/file-roller/file-roller-2.14.0.ebuild9
-rw-r--r--app-arch/file-roller/files/file-roller-2.14.0-double_unpack.patch19
-rw-r--r--app-arch/file-roller/files/file-roller-2.14.0-drag_move.patch16
4 files changed, 48 insertions, 2 deletions
diff --git a/app-arch/file-roller/ChangeLog b/app-arch/file-roller/ChangeLog
index 6704a4258ced..1b8a3f087706 100644
--- a/app-arch/file-roller/ChangeLog
+++ b/app-arch/file-roller/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/file-roller
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.162 2006/03/24 15:13:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.163 2006/04/04 13:50:50 foser Exp $
+
+ 04 Apr 2006; Marinus Schraal <foser@gentoo.org>
+ files/file-roller-2.14.0-drag_move.patch, files/file-roller-2.14.0-double_unpack.patch :
+ Add patches to fix a crasher and fix dnd behaviour
24 Mar 2006; Aron Griffis <agriffis@gentoo.org> file-roller-2.12.3.ebuild:
Mark 2.12.3 stable on ia64
diff --git a/app-arch/file-roller/file-roller-2.14.0.ebuild b/app-arch/file-roller/file-roller-2.14.0.ebuild
index e186d9f2efab..991f284f81c1 100644
--- a/app-arch/file-roller/file-roller-2.14.0.ebuild
+++ b/app-arch/file-roller/file-roller-2.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.14.0.ebuild,v 1.1 2006/03/14 22:38:51 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-2.14.0.ebuild,v 1.2 2006/04/04 13:50:50 foser Exp $
inherit eutils gnome2
@@ -47,6 +47,13 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.10-use_fr_rpm2cpio.patch
# fix xmllint failure
epatch ${FILESDIR}/${PN}-2.13.2-xmllint.patch
+
+ cd ${S}/src
+ # fix dnd drop to move instead of copy (http://bugzilla.gnome.org/show_bug.cgi?id=335659)
+ epatch ${FILESDIR}/${P}-drag_move.patch
+ # fix crasher on double unpack (http://bugzilla.gnome.org/show_bug.cgi?id=336854)
+ epatch ${FILESDIR}/${P}-double_unpack.patch
+
}
src_install() {
diff --git a/app-arch/file-roller/files/file-roller-2.14.0-double_unpack.patch b/app-arch/file-roller/files/file-roller-2.14.0-double_unpack.patch
new file mode 100644
index 000000000000..855910f84095
--- /dev/null
+++ b/app-arch/file-roller/files/file-roller-2.14.0-double_unpack.patch
@@ -0,0 +1,19 @@
+===================================================================
+RCS file: /cvs/gnome/file-roller/src/window.c,v
+retrieving revision 1.160
+retrieving revision 1.161
+diff -u -r1.160 -r1.161
+--- window.c 2006/04/03 12:44:13 1.160
++++ window.c 2006/04/04 11:25:47 1.161
+@@ -4793,6 +4793,11 @@
+ junk_paths,
+ password);
+
++ if (window->archive->process->n_comm < 0) { /* no file to extract */
++ fr_process_start (window->archive->process);
++ return;
++ }
++
+ fr_process_set_continue_func (window->archive->process,
+ extract__content_is_singleton,
+ window);
diff --git a/app-arch/file-roller/files/file-roller-2.14.0-drag_move.patch b/app-arch/file-roller/files/file-roller-2.14.0-drag_move.patch
new file mode 100644
index 000000000000..c6fe592c62c3
--- /dev/null
+++ b/app-arch/file-roller/files/file-roller-2.14.0-drag_move.patch
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /cvs/gnome/file-roller/src/eggtreemultidnd.c,v
+retrieving revision 1.4
+retrieving revision 1.5
+diff -u -r1.4 -r1.5
+--- eggtreemultidnd.c 2005/12/10 11:19:48 1.4
++++ eggtreemultidnd.c 2006/04/04 12:35:32 1.5
+@@ -311,7 +311,7 @@
+
+ context = gtk_drag_begin (widget,
+ target_list,
+- GDK_ACTION_COPY,
++ GDK_ACTION_MOVE,
+ priv_data->pressed_button,
+ (GdkEvent*)event);
+ set_context_data (context, path_list);