summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-05 22:55:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-05 22:55:34 +0000
commit8ee541319f1a6d4d586f1cf3933c7d67386fd1a7 (patch)
tree9f6c80615ef1c51c3156e6687ceae77ed186a5a1 /app-arch/karchiver
parentVersion bump. This fixes bug #135416. (diff)
downloadgentoo-2-8ee541319f1a6d4d586f1cf3933c7d67386fd1a7.tar.gz
gentoo-2-8ee541319f1a6d4d586f1cf3933c7d67386fd1a7.tar.bz2
gentoo-2-8ee541319f1a6d4d586f1cf3933c7d67386fd1a7.zip
Add patch for GCC 4.1 compatibility from Piotr Jaroszynski in bug #135635 reported by Robert Spencer.
(Portage version: 2.1_rc4-r2)
Diffstat (limited to 'app-arch/karchiver')
-rw-r--r--app-arch/karchiver/ChangeLog9
-rw-r--r--app-arch/karchiver/files/digest-karchiver-3.1.1-r12
-rw-r--r--app-arch/karchiver/files/karchiver-3.1.1-gcc41.patch11
-rw-r--r--app-arch/karchiver/karchiver-3.1.1-r1.ebuild6
4 files changed, 24 insertions, 4 deletions
diff --git a/app-arch/karchiver/ChangeLog b/app-arch/karchiver/ChangeLog
index c20e0f4df090..ba34265f2392 100644
--- a/app-arch/karchiver/ChangeLog
+++ b/app-arch/karchiver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/karchiver
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/karchiver/ChangeLog,v 1.27 2005/08/09 23:21:04 metalgod Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/karchiver/ChangeLog,v 1.28 2006/06/05 22:55:34 flameeyes Exp $
+
+ 05 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/karchiver-3.1.1-gcc41.patch, karchiver-3.1.1-r1.ebuild:
+ Add patch for GCC 4.1 compatibility from Piotr Jaroszynski in bug #135635
+ reported by Robert Spencer.
10 Aug 2005; Luis Medinas <metalgod@gentoo.org> karchiver-3.1.1-r1.ebuild:
Marked Testing on AMD64. Closes bug #101870 .
diff --git a/app-arch/karchiver/files/digest-karchiver-3.1.1-r1 b/app-arch/karchiver/files/digest-karchiver-3.1.1-r1
index 5f5bde719d1d..41d29563d684 100644
--- a/app-arch/karchiver/files/digest-karchiver-3.1.1-r1
+++ b/app-arch/karchiver/files/digest-karchiver-3.1.1-r1
@@ -1 +1,3 @@
MD5 820386e5dae11957116298cda7ae052f karchiver-3.1.1.tar.bz2 1708212
+RMD160 387887edafeb68de5fe478fcd1d532dce9e1d485 karchiver-3.1.1.tar.bz2 1708212
+SHA256 6670bc4bee8f587f1d1b34cd1af24d66970f3c5574e733c8d8736549c924f9e6 karchiver-3.1.1.tar.bz2 1708212
diff --git a/app-arch/karchiver/files/karchiver-3.1.1-gcc41.patch b/app-arch/karchiver/files/karchiver-3.1.1-gcc41.patch
new file mode 100644
index 000000000000..52a8b4785603
--- /dev/null
+++ b/app-arch/karchiver/files/karchiver-3.1.1-gcc41.patch
@@ -0,0 +1,11 @@
+--- karchiver-3.1.1-orig/karchiver/cpreferences.h 2005-02-28 16:33:37.000000000 +0100
++++ karchiver-3.1.1/karchiver/cpreferences.h 2006-06-06 00:14:43.000000000 +0200
+@@ -71,7 +71,7 @@
+ * uncompressing gzip and bzip2 archives */
+ bool getOverwriteGzip();
+ /** return true if we will use RAR header encryption */
+- bool CPreferences::getHeaderEncryption();
++ bool getHeaderEncryption();
+ /** return 0 if we'll display small icons, 1 for medium,
+ * 2 for large */
+ int getSizeofIconListe();
diff --git a/app-arch/karchiver/karchiver-3.1.1-r1.ebuild b/app-arch/karchiver/karchiver-3.1.1-r1.ebuild
index c175a67e2e0e..422b8073ffcc 100644
--- a/app-arch/karchiver/karchiver-3.1.1-r1.ebuild
+++ b/app-arch/karchiver/karchiver-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/karchiver/karchiver-3.1.1-r1.ebuild,v 1.5 2005/08/09 23:21:04 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/karchiver/karchiver-3.1.1-r1.ebuild,v 1.6 2006/06/05 22:55:34 flameeyes Exp $
inherit kde
@@ -15,6 +15,8 @@ IUSE=""
need-kde 3.1
+PATCHES="${FILESDIR}/${P}-gcc41.patch"
+
# Nasty packaging...
src_unpack() {
kde_src_unpack