summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2011-07-02 18:07:01 +0000
committerSerkan Kaba <serkan@gentoo.org>2011-07-02 18:07:01 +0000
commit106f9e44a399e81f3f76f1c8b801a3e782364605 (patch)
tree42cf02a37b9c666bcd68b57b19671ffdfd3225e5 /app-arch/rar
parentalpha/arm/ia64/sh/sparc stable wrt #372889 (diff)
downloadgentoo-2-106f9e44a399e81f3f76f1c8b801a3e782364605.tar.gz
gentoo-2-106f9e44a399e81f3f76f1c8b801a3e782364605.tar.bz2
gentoo-2-106f9e44a399e81f3f76f1c8b801a3e782364605.zip
Version bump to fix bug #373833 reported by Vasileios Lourdas <bugzilla@lourdas.name>
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/rar')
-rw-r--r--app-arch/rar/ChangeLog8
-rw-r--r--app-arch/rar/rar-4.0.1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/app-arch/rar/ChangeLog b/app-arch/rar/ChangeLog
index 517105385304..c2401758c2c7 100644
--- a/app-arch/rar/ChangeLog
+++ b/app-arch/rar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/rar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rar/ChangeLog,v 1.69 2011/03/09 21:06:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rar/ChangeLog,v 1.70 2011/07/02 18:07:01 serkan Exp $
+
+*rar-4.0.1 (02 Jul 2011)
+
+ 02 Jul 2011; Serkan Kaba <serkan@gentoo.org> +rar-4.0.1.ebuild:
+ Version bump to fix bug #373833 reported by Vasileios Lourdas
+ <bugzilla@lourdas.name>
*rar-4.0.0 (09 Mar 2011)
diff --git a/app-arch/rar/rar-4.0.1.ebuild b/app-arch/rar/rar-4.0.1.ebuild
new file mode 100644
index 000000000000..f746a12a6052
--- /dev/null
+++ b/app-arch/rar/rar-4.0.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rar/rar-4.0.1.ebuild,v 1.1 2011/07/02 18:07:01 serkan Exp $
+
+DESCRIPTION="RAR compressor/uncompressor"
+HOMEPAGE="http://www.rarsoft.com/"
+URI_x86="http://www.rarlab.com/rar/rarlinux-${PV}.tar.gz"
+URI_amd64="http://www.rarlab.com/rar/rarlinux-x64-${PV}.tar.gz"
+URI_w64="http://www.rarlab.com/rar/winrar-x64-${PV//.}.exe"
+SRC_URI="x86? ( ${URI_x86} )
+ amd64? ( ${URI_amd64} )
+ all_sfx? (
+ ${URI_x86}
+ ${URI_amd64}
+ ${URI_w64}
+ )"
+
+LICENSE="RAR"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="all_sfx static"
+
+DEPEND="all_sfx? ( app-arch/unrar )"
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}/${PN}
+
+QA_DT_HASH="opt/rar/default.sfx
+ opt/rar/default-elf32.sfx
+ opt/rar/default-elf64.sfx
+ opt/rar/default-win32.sfx
+ opt/rar/default-win64.sfx
+ opt/rar/WinCon.SFX
+ opt/rar/WinCon64.SFX
+ opt/rar/Zip.SFX
+ opt/rar/Zip64.SFX
+ opt/rar/unrar
+ opt/rar/rar"
+QA_PRESTRIPPED=${QA_DT_HASH}
+
+src_unpack() {
+ use x86 && unpack ${URI_x86##*/}
+ use amd64 && unpack ${URI_amd64##*/}
+ rm -f "${S}"/license.txt
+ if use all_sfx ; then
+ mkdir sfx
+ cd sfx
+ unpack ${URI_x86##*/}
+ mv rar/default.sfx default-elf32.sfx || die
+ unpack ${URI_amd64##*/}
+ mv rar/default.sfx default-elf64.sfx || die
+ ln -s "${DISTDIR}"/${URI_w64##*/} w64.rar
+ unpack ./w64.rar
+ mv Default.SFX default-win32.sfx || die
+ mv Default64.SFX default-win64.sfx || die
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ exeinto /opt/rar
+ doexe rar unrar || die
+ use static && { newexe rar_static rar || die ; }
+
+ dodir /opt/bin
+ dosym ../rar/rar /opt/bin/rar || die
+ dosym ../rar/unrar /opt/bin/unrar || die
+
+ insinto /opt/rar
+ if use all_sfx ; then
+ doins "${WORKDIR}"/sfx/*.{sfx,SFX} || die
+ else
+ doins default.sfx || die
+ fi
+ doins rarfiles.lst || die
+ dodoc *.txt
+}