summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-04-03 18:22:16 +0000
committerMike Frysinger <vapier@gentoo.org>2014-04-03 18:22:16 +0000
commita78fbd078770aa19798ac2a2c1c39cb52597d93c (patch)
tree52820ae7fb590b2b2e6e358316ea4e8156edd10b /app-arch/snappy/snappy-1.1.2-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-a78fbd078770aa19798ac2a2c1c39cb52597d93c.tar.gz
gentoo-2-a78fbd078770aa19798ac2a2c1c39cb52597d93c.tar.bz2
gentoo-2-a78fbd078770aa19798ac2a2c1c39cb52597d93c.zip
Convert to autotools-multilib #504756 by David Heidelberger.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-arch/snappy/snappy-1.1.2-r1.ebuild')
-rw-r--r--app-arch/snappy/snappy-1.1.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/snappy/snappy-1.1.2-r1.ebuild b/app-arch/snappy/snappy-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..f77c483c89a2
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/snappy/snappy-1.1.2-r1.ebuild,v 1.1 2014/04/03 18:22:16 vapier Exp $
+
+EAPI="5"
+
+inherit eutils autotools-multilib
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+# upstream uses google drive which has hash-based URLS
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+
+ # Avoid automagic lzo and gzip by not checking for it
+ sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
+
+ # don't install unwanted files
+ sed -i 's/COPYING INSTALL//' Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}