summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-11 17:46:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-11 17:46:45 +0000
commita0f5d76674753743984a930d2911927a371a33e0 (patch)
tree29b59c996cf83e412ed0505db23a577e9ab4bfa3 /app-arch/tar
parentStable on amd64. (Manifest recommit) (diff)
downloadgentoo-2-a0f5d76674753743984a930d2911927a371a33e0.tar.gz
gentoo-2-a0f5d76674753743984a930d2911927a371a33e0.tar.bz2
gentoo-2-a0f5d76674753743984a930d2911927a371a33e0.zip
restore old tar for uclibc systems
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/files/digest-tar-1.13.92-r31
-rw-r--r--app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch34
-rw-r--r--app-arch/tar/files/tar-1.13.92-fix-one_file_system.patch21
-rw-r--r--app-arch/tar/tar-1.13.92-r3.ebuild65
4 files changed, 121 insertions, 0 deletions
diff --git a/app-arch/tar/files/digest-tar-1.13.92-r3 b/app-arch/tar/files/digest-tar-1.13.92-r3
new file mode 100644
index 000000000000..6590deb15c11
--- /dev/null
+++ b/app-arch/tar/files/digest-tar-1.13.92-r3
@@ -0,0 +1 @@
+MD5 fdfffdd8141a00ea72c16c34b486a00a tar-1.13.92.tar.bz2 1043316
diff --git a/app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch b/app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch
new file mode 100644
index 000000000000..aae49762c6a0
--- /dev/null
+++ b/app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch
@@ -0,0 +1,34 @@
+===================================================================
+RCS file: /cvsroot/tar/cvsroot/tar/tar/src/names.c,v
+retrieving revision 1.36
+retrieving revision 1.37
+diff -u -r1.36 -r1.37
+--- tar/tar/src/names.c 2003/11/17 07:39:33 1.36
++++ tar/tar/src/names.c 2003/12/25 10:19:40 1.37
+@@ -1021,13 +1021,8 @@
+
+ for (p = file_name + prefix_len; *p; )
+ {
+- if (p[0] == '.')
+- {
+- if (p[1] == '.' && (ISSLASH (p[2]) || !p[2]))
+- prefix_len = p + 2 - file_name;
+- else if (ISSLASH (p[1]))
+- prefix_len = p + 1 - file_name;
+- }
++ if (p[0] == '.' && p[1] == '.' && (ISSLASH (p[2]) || !p[2]))
++ prefix_len = p + 2 - file_name;
+
+ do
+ {
+@@ -1072,8 +1067,8 @@
+ };
+ WARN ((0, 0, _(diagnostic[link_target])));
+ }
+-
+- p = ISSLASH (file_name[strlen(file_name)-1]) ? "./" : ".";
++
++ p = ".";
+ }
+
+ return (char *) p;
diff --git a/app-arch/tar/files/tar-1.13.92-fix-one_file_system.patch b/app-arch/tar/files/tar-1.13.92-fix-one_file_system.patch
new file mode 100644
index 000000000000..d45f0c0611fe
--- /dev/null
+++ b/app-arch/tar/files/tar-1.13.92-fix-one_file_system.patch
@@ -0,0 +1,21 @@
+===================================================================
+RCS file: /cvsroot/tar/cvsroot/tar/tar/src/create.c,v
+retrieving revision 1.73
+retrieving revision 1.74
+diff -u -r1.73 -r1.74
+--- tar/tar/src/create.c 2003/12/25 10:18:37 1.73
++++ tar/tar/src/create.c 2004/01/03 11:45:31 1.74
+@@ -981,9 +981,11 @@
+ return;
+ }
+ }
+- else if (!recursion_option)
++
++ if (!recursion_option)
+ return;
+- else if (one_file_system_option
++
++ if (one_file_system_option
+ && !top_level
+ && parent_device != stat->stat.st_dev)
+ {
diff --git a/app-arch/tar/tar-1.13.92-r3.ebuild b/app-arch/tar/tar-1.13.92-r3.ebuild
new file mode 100644
index 000000000000..a74b55a82cd4
--- /dev/null
+++ b/app-arch/tar/tar-1.13.92-r3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.92-r3.ebuild,v 1.17 2004/10/11 17:46:45 vapier Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="Use this to make tarballs :)"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="ftp://alpha.gnu.org/pub/pub/gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ~ia64 ~ppc64 s390"
+IUSE="nls static build"
+
+DEPEND="app-arch/gzip
+ app-arch/bzip2
+ app-arch/ncompress"
+
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.35 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Do not strip './' in path elements, as they are valid, bug #37132
+ epatch "${FILESDIR}/${P}-dont-strip-dot_slash.patch"
+ # Fix -l, --one-file-system option to actually work.
+ epatch "${FILESDIR}/${P}-fix-one_file_system.patch"
+ # Fix configure scripts to support linux-mips targets
+ gnuconfig_update
+}
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ --libexecdir=/usr/lib/misc \
+ $(use_enable nls) || die
+
+ if use static ; then
+ emake LDFLAGS=-static || die "emake failed"
+ else
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ #FHS 2.1 stuff
+ dodir /usr/sbin
+ cd "${D}"
+ mv usr/lib/misc/rmt usr/sbin/rmt.gnu
+ dosym rmt.gnu /usr/sbin/rmt
+ # a nasty yet required symlink:
+ dodir /etc
+ dosym /usr/sbin/rmt /etc/rmt
+ cd "${S}"
+ if use build ; then
+ rm -rf "${D}/usr/share"
+ rm -rf ${D}/usr/sbin ${D}/etc/rmt
+ else
+ dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
+ doman "${FILESDIR}/tar.1"
+ fi
+}