summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2004-03-20 14:17:31 +0000
committerDominik Stadler <centic@gentoo.org>2004-03-20 14:17:31 +0000
commit402e5c05d41afdf2eba111a3400d6f16c6ae4564 (patch)
tree890c63358a85d4cb6e05fa16e91a64f8936ed426 /app-arch/tob
parentAdded a patch to solve GCC3.3 compilation issues. Closes bug #45147. (Manifes... (diff)
downloadgentoo-2-402e5c05d41afdf2eba111a3400d6f16c6ae4564.tar.gz
gentoo-2-402e5c05d41afdf2eba111a3400d6f16c6ae4564.tar.bz2
gentoo-2-402e5c05d41afdf2eba111a3400d6f16c6ae4564.zip
Add new ebuild.
Diffstat (limited to 'app-arch/tob')
-rw-r--r--app-arch/tob/ChangeLog10
-rw-r--r--app-arch/tob/Manifest4
-rw-r--r--app-arch/tob/files/digest-tob-0.261
-rw-r--r--app-arch/tob/files/tob-0.26-no-maketemp-warn.diff12
-rw-r--r--app-arch/tob/metadata.xml8
-rw-r--r--app-arch/tob/tob-0.26.ebuild40
6 files changed, 75 insertions, 0 deletions
diff --git a/app-arch/tob/ChangeLog b/app-arch/tob/ChangeLog
new file mode 100644
index 000000000000..aa8eb76e4fc5
--- /dev/null
+++ b/app-arch/tob/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/tob
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tob/ChangeLog,v 1.1 2004/03/20 14:17:31 centic Exp $
+
+*tob-0.26 (20 Mar 2004)
+
+ 20 Mar 2004; Dominik Stadler <centic@gentoo.org> tob-0.26.ebuild,
+ files/tob-0.26-no-maketemp-warn.diff:
+ New ebuild
+
diff --git a/app-arch/tob/Manifest b/app-arch/tob/Manifest
new file mode 100644
index 000000000000..715b1e55e4f7
--- /dev/null
+++ b/app-arch/tob/Manifest
@@ -0,0 +1,4 @@
+MD5 09e31bc163700d25be14ba2ddb5a2332 tob-0.26.ebuild 850
+MD5 b9628c13e56af8c26358d24eefefec6b files/digest-tob-0.25 57
+MD5 16e9d7787c776a93e8aecfe45acf4e49 files/digest-tob-0.26 57
+MD5 093a36053cf0fe7130b2b0cea3da165e files/tob-0.26-no-maketemp-warn.diff 386
diff --git a/app-arch/tob/files/digest-tob-0.26 b/app-arch/tob/files/digest-tob-0.26
new file mode 100644
index 000000000000..51fb9e358fa6
--- /dev/null
+++ b/app-arch/tob/files/digest-tob-0.26
@@ -0,0 +1 @@
+MD5 de964a6e1b2d886591c0f324f291ae83 tob-0.26.tgz 107711
diff --git a/app-arch/tob/files/tob-0.26-no-maketemp-warn.diff b/app-arch/tob/files/tob-0.26-no-maketemp-warn.diff
new file mode 100644
index 000000000000..af346d111353
--- /dev/null
+++ b/app-arch/tob/files/tob-0.26-no-maketemp-warn.diff
@@ -0,0 +1,12 @@
+diff -u tob-0.26/tob tob-0.26.new/tob
+--- tob-0.26/tob 2003-12-22 01:25:17.000000000 +0100
++++ tob-0.26.new/tob 2004-03-20 10:30:09.916597016 +0100
+@@ -61,7 +61,7 @@
+ ## 16 May 1998
+ ##
+ ## Smartened up by Stephen van Egmond <svanegmond@tinyplanet.ca> 2003/10/30
+-MKTEMP=`which maketemp`;
++MKTEMP=`which maketemp 2> /dev/null`;
+ if [ ! -x "$MKTEMP" ]; then
+ MKTEMP=`which mktemp`;
+ fi
diff --git a/app-arch/tob/metadata.xml b/app-arch/tob/metadata.xml
new file mode 100644
index 000000000000..3db6319a8af1
--- /dev/null
+++ b/app-arch/tob/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>centic@gentoo.org</email>
+ <name>Dominik Stadler</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-arch/tob/tob-0.26.ebuild b/app-arch/tob/tob-0.26.ebuild
new file mode 100644
index 000000000000..c4806256c9a2
--- /dev/null
+++ b/app-arch/tob/tob-0.26.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tob/tob-0.26.ebuild,v 1.1 2004/03/20 14:17:31 centic Exp $
+
+DESCRIPTION="A general driver for making and maintaining backups."
+HOMEPAGE="http://tinyplanet.ca/projects/tob/"
+SRC_URI="http://tinyplanet.ca/projects/tob/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="app-arch/afio"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "$FILESDIR/${P}-no-maketemp-warn.diff"
+}
+
+src_compile() {
+ # no compilation required, only a perl-script
+ einfo "No compilation necessary..."
+}
+
+src_install() {
+ # simply install all the parts into the correct places
+ dodir /usr/sbin
+ dosbin tob
+ dodir /etc/tob/volumes
+ cp tob.rc ${D}/etc/tob/tob.rc
+ cp example.* ${D}/etc/tob/volumes
+ doman tob.8
+ dodoc COPYING README
+ docinto doc
+ dodoc doc/*
+ docinto sample-rc
+ dodoc sample-rc/*
+}
+