summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-05-07 19:48:09 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-05-07 19:48:09 +0000
commit8c7539b9dd47ac83123ded3a5e9f7b719cc38863 (patch)
tree9b9beec9c0ada2b051f0e7822b12e3feb3821418 /app-arch/upx-ucl/upx-ucl-3.02.ebuild
parentfix ChangeLog header (diff)
downloadgentoo-2-8c7539b9dd47ac83123ded3a5e9f7b719cc38863.tar.gz
gentoo-2-8c7539b9dd47ac83123ded3a5e9f7b719cc38863.tar.bz2
gentoo-2-8c7539b9dd47ac83123ded3a5e9f7b719cc38863.zip
Version bump wrt bug #218472
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-arch/upx-ucl/upx-ucl-3.02.ebuild')
-rw-r--r--app-arch/upx-ucl/upx-ucl-3.02.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-arch/upx-ucl/upx-ucl-3.02.ebuild b/app-arch/upx-ucl/upx-ucl-3.02.ebuild
new file mode 100644
index 000000000000..6fbc50949519
--- /dev/null
+++ b/app-arch/upx-ucl/upx-ucl-3.02.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/upx-ucl/upx-ucl-3.02.ebuild,v 1.1 2008/05/07 19:48:09 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+LZMA_VER=4.57
+MY_P="${P/-ucl/}-src"
+DESCRIPTION="upx is the Ultimate Packer for eXecutables."
+HOMEPAGE="http://upx.sourceforge.net"
+SRC_URI="http://upx.sourceforge.net/download/${MY_P}.tar.bz2
+ mirror://sourceforge/sevenzip/lzma${LZMA_VER/.}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE=""
+
+DEPEND=">=dev-libs/ucl-1.02
+ dev-lang/perl
+ !app-arch/upx"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ mkdir "${WORKDIR}"/lzma-${LZMA_VER}
+ cd "${WORKDIR}"/lzma-${LZMA_VER}
+ unpack lzma${LZMA_VER/.}.tar.bz2
+}
+
+src_compile() {
+ tc-export CXX
+ emake UPX_LZMADIR="${WORKDIR}"/lzma-${LZMA_VER} all || die
+}
+
+src_install() {
+ newbin src/upx.out upx
+
+ dodoc BUGS LICENSE NEWS PROJECTS README* THANKS TODO doc/upx.doc doc/*.txt
+ dohtml doc/upx.html
+ doman doc/upx.1
+}