summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-04-20 12:46:37 +0000
committerDror Levin <spatz@gentoo.org>2010-04-20 12:46:37 +0000
commit8ef26ad81378637c6e8979c164275effc2675f73 (patch)
treefacbfe927478ccdb8d900230e90d44e67b8a307f /app-arch
parentUSE="svg" wrt #313435 by Roman v. Gemmeren. (diff)
downloadgentoo-2-8ef26ad81378637c6e8979c164275effc2675f73.tar.gz
gentoo-2-8ef26ad81378637c6e8979c164275effc2675f73.tar.bz2
gentoo-2-8ef26ad81378637c6e8979c164275effc2675f73.zip
Version bump, bug 316113. Remove old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pbzip2/ChangeLog8
-rw-r--r--app-arch/pbzip2/pbzip2-1.1.1.ebuild (renamed from app-arch/pbzip2/pbzip2-1.0.5-r1.ebuild)28
2 files changed, 24 insertions, 12 deletions
diff --git a/app-arch/pbzip2/ChangeLog b/app-arch/pbzip2/ChangeLog
index 55af600fd491..68a60110dabc 100644
--- a/app-arch/pbzip2/ChangeLog
+++ b/app-arch/pbzip2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/pbzip2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.83 2010/04/06 07:30:44 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/ChangeLog,v 1.84 2010/04/20 12:46:37 spatz Exp $
+
+*pbzip2-1.1.1 (20 Apr 2010)
+
+ 20 Apr 2010; Dror Levin <spatz@gentoo.org> -pbzip2-1.0.5-r1.ebuild,
+ +pbzip2-1.1.1.ebuild:
+ Version bump, bug 316113. Remove old.
06 Apr 2010; Markos Chandras <hwoarang@gentoo.org> pbzip2-1.0.5-r2.ebuild:
Stable on amd64 wrt bug #300113
diff --git a/app-arch/pbzip2/pbzip2-1.0.5-r1.ebuild b/app-arch/pbzip2/pbzip2-1.1.1.ebuild
index 617157e9026a..6515ee505588 100644
--- a/app-arch/pbzip2/pbzip2-1.0.5-r1.ebuild
+++ b/app-arch/pbzip2/pbzip2-1.1.1.ebuild
@@ -1,29 +1,29 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.0.5-r1.ebuild,v 1.7 2009/08/09 15:37:00 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pbzip2/pbzip2-1.1.1.ebuild,v 1.1 2010/04/20 12:46:37 spatz Exp $
+
+EAPI=2
inherit multilib eutils
-DESCRIPTION="parallel bzip2 (de)compressor using libbz2"
+DESCRIPTION="Parallel bzip2 (de)compressor using libbz2"
HOMEPAGE="http://compression.ca/pbzip2/"
SRC_URI="http://compression.ca/${PN}/${P}.tar.gz"
LICENSE="PBZIP2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="static"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="static symlink"
DEPEND="app-arch/bzip2"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- sed -e 's:^CFLAGS = .*$:#&:g' -e 's:g++:$(CXX):g' -i ${P}/Makefile || die
- epatch "${FILESDIR}"/${P}-ldflags.patch
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.0-makefile.patch
+ tc-export CXX
}
src_compile() {
- tc-export CXX
if use static ; then
cp -f /usr/$(get_libdir)/libbz2.a "${S}"
emake pbzip2-static || die "Failed to build"
@@ -34,7 +34,13 @@ src_compile() {
src_install() {
dobin pbzip2 || die "Failed to install"
- dodoc AUTHORS ChangeLog README
+ dodoc AUTHORS ChangeLog README || die
doman pbzip2.1 || die "Failed to install man page"
dosym /usr/bin/pbzip2 /usr/bin/pbunzip2
+
+ if use symlink; then
+ dosym /usr/bin/pbzip2 /usr/bin/bzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bunzip2
+ dosym /usr/bin/pbzip2 /usr/bin/bzcat
+ fi
}