summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-07-01 16:06:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-07-01 16:06:06 +0000
commited36c1cc7e397d823917aeb7e3ec96bd9780277d (patch)
tree372731b1b2b6be52d53a6c530256878cee1da6a5 /app-arch
parentBump for 2.14.2 (diff)
downloadgentoo-2-ed36c1cc7e397d823917aeb7e3ec96bd9780277d.tar.gz
gentoo-2-ed36c1cc7e397d823917aeb7e3ec96bd9780277d.tar.bz2
gentoo-2-ed36c1cc7e397d823917aeb7e3ec96bd9780277d.zip
Some cleanups from James
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/ipkg-utils/ChangeLog6
-rw-r--r--app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch29
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.ebuild16
3 files changed, 43 insertions, 8 deletions
diff --git a/app-arch/ipkg-utils/ChangeLog b/app-arch/ipkg-utils/ChangeLog
index 1468813b30c5..5de5d3ba7120 100644
--- a/app-arch/ipkg-utils/ChangeLog
+++ b/app-arch/ipkg-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/ipkg-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.5 2006/06/07 17:44:07 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.6 2006/07/01 16:06:06 seemant Exp $
+
+ 01 Jul 2006; Seemant Kulleen <seemant@gentoo.org>
+ +files/ipkg-utils-1.7-build_fixes.patch, ipkg-utils-1.7.ebuild:
+ Some cleanups from James
07 Jun 2006; Seemant Kulleen <seemant@gentoo.org> metadata.xml:
James Rowe is taking over maintainership of this package. I'll be acting as
diff --git a/app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch b/app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch
new file mode 100644
index 000000000000..c2044db72d77
--- /dev/null
+++ b/app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch
@@ -0,0 +1,29 @@
+Index: ipkg-utils-1.7/Makefile
+===================================================================
+--- ipkg-utils-1.7/Makefile {cset 1fe36b83-662c-4d43-b5df-915184007abf}
++++ ipkg-utils-1.7/Makefile {local clone}
+@@ -1,20 +1,19 @@
+ UTILS = ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload
+
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ all: build
+
+ build: ipkg-compare-versions
+- python setup.py build
+
+ ipkg-compare-versions: ipkg-compare-versions.c
+ $(CC) $(CFLAGS) -o ipkg-compare-versions ipkg-compare-versions.c
+
+ install: ${UTILS}
+- cp ${UTILS} $(PREFIX)/bin
+- python setup.py install
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ cp ${UTILS} $(DESTDIR)$(PREFIX)/bin
+ chmod agu+rx ipkg-make-index
+- cp -f ipkg-make-index $(PREFIX)/bin
++ cp -f ipkg-make-index $(DESTDIR)$(PREFIX)/bin
+
+ binary: build
+ mkdir -p ipkg-build-binary/usr/bin
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
index f2df06c13de2..a5cd0bad8183 100644
--- a/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild,v 1.5 2006/01/20 22:03:21 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.ebuild,v 1.6 2006/07/01 16:06:06 seemant Exp $
-inherit distutils
+inherit distutils eutils toolchain-funcs
DESCRIPTION="Tools for working with the ipkg binary package format"
HOMEPAGE="http://www.openembedded.org/"
@@ -14,13 +14,15 @@ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
DEPEND="dev-lang/python"
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ epatch ${FILESDIR}/${P}-build_fixes.patch
+}
+
src_compile() {
- sed -i -e 's#^PREFIX=.*#PREFIX=/usr#' Makefile || die 'prefix fix failed'
- sed -i -e 's#$(PREFIX)#$(DESTDIR)$(PREFIX)#' Makefile || die 'destdir fix failed'
- sed -i -e '/^install:/s#^\(.*\)$#\1\n\tmkdir -p $(DESTDIR)$(PREFIX)/bin#' Makefile || die 'mkdir fix failed'
- sed -i -e '/python setup.py/d' Makefile || die 'sandbox fix failed'
distutils_src_compile
- emake || die "emake failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
}
src_install() {