summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-19 13:47:56 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-19 13:47:56 +0000
commit8c68517cf8e15c3f5ce5868887613182ce31cd74 (patch)
tree3d2b4f13e0c79197538436cf69aeb46429fda258 /app-backup/bacula
parentVersion bump (diff)
downloadgentoo-2-8c68517cf8e15c3f5ce5868887613182ce31cd74.tar.gz
gentoo-2-8c68517cf8e15c3f5ce5868887613182ce31cd74.tar.bz2
gentoo-2-8c68517cf8e15c3f5ce5868887613182ce31cd74.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'app-backup/bacula')
-rw-r--r--app-backup/bacula/ChangeLog7
-rw-r--r--app-backup/bacula/bacula-2.4.4.ebuild21
2 files changed, 12 insertions, 16 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index 2d9a60d63caf..4545de6411c5 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-backup/bacula
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.73 2009/02/03 15:25:17 wschlich Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.74 2009/08/19 13:47:56 betelgeuse Exp $
+
+ 19 Aug 2009; Petteri Räty <betelgeuse@gentoo.org> bacula-2.4.4.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
03 Feb 2009; Wolfram Schlich <wschlich@gentoo.org>
-files/2.0.3/bacula-all-init, -files/2.0.3/bacula-dir-init,
diff --git a/app-backup/bacula/bacula-2.4.4.ebuild b/app-backup/bacula/bacula-2.4.4.ebuild
index 454d6726eba2..38bc2473cc32 100644
--- a/app-backup/bacula/bacula-2.4.4.ebuild
+++ b/app-backup/bacula/bacula-2.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-2.4.4.ebuild,v 1.1 2009/01/28 09:19:28 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-2.4.4.ebuild,v 1.2 2009/08/19 13:47:56 betelgeuse Exp $
#
# TODO:
@@ -20,7 +20,7 @@
# - bacula >=2.4.0 supports --without-qwt -- reflect with USE=qwt?
#
-EAPI="1"
+EAPI="2"
inherit eutils
IUSE="bacula-clientonly bacula-console bacula-nodir bacula-nosd doc gnome ipv6 logrotate logwatch mysql postgres python qt4 readline sqlite sqlite3 ssl static tcpd wxwindows X"
@@ -72,7 +72,7 @@ DEPEND="
readline? ( >=sys-libs/readline-4.1 )
doc? (
virtual/ghostscript
- dev-tex/latex2html
+ dev-tex/latex2html[png]
)"
RDEPEND="${DEPEND}
!bacula-clientonly? (
@@ -136,10 +136,7 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# adjusts default configuration files for several binaries
# to /etc/bacula/<config> instead of ./<config>
pushd src && epatch "${FILESDIR}/${PV}/${PN}"-default-configs.patch && popd
@@ -152,13 +149,7 @@ src_unpack() {
&& epatch "${FILESDIR}"/${PV}/${PV}-*.patch
}
-src_compile() {
- if useq doc && has_version dev-tex/latex2html && ! built_with_use dev-tex/latex2html png; then
- eerror "${PN} needs the PNG support of latex2html"
- eerror "Please re-emerge dev-tex/latex2html with USE=png"
- die "need dev-tex/latex2html built with png USE flag"
- fi
-
+src_configure() {
local myconf=''
if useq bacula-clientonly; then
@@ -226,7 +217,9 @@ src_compile() {
--host=${CHOST} \
${myconf} \
|| die "configure failed"
+}
+src_compile() {
emake || die "emake failed"
# build various GUIs from bacula-gui tarball