summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-05-11 13:00:54 +0000
committerHanno Böck <hanno@gentoo.org>2009-05-11 13:00:54 +0000
commitffa6534ee27b0b5dd906aef2cdc8d103bc94eaee (patch)
tree898ae0ce6ca4d5a1d4b848fa7af568b69d4af556 /app-backup/duplicity/duplicity-0.5.17.ebuild
parentVersion bump (diff)
downloadgentoo-2-ffa6534ee27b0b5dd906aef2cdc8d103bc94eaee.tar.gz
gentoo-2-ffa6534ee27b0b5dd906aef2cdc8d103bc94eaee.tar.bz2
gentoo-2-ffa6534ee27b0b5dd906aef2cdc8d103bc94eaee.zip
duplicity bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-backup/duplicity/duplicity-0.5.17.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-0.5.17.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-backup/duplicity/duplicity-0.5.17.ebuild b/app-backup/duplicity/duplicity-0.5.17.ebuild
new file mode 100644
index 000000000000..5769acd5e482
--- /dev/null
+++ b/app-backup/duplicity/duplicity-0.5.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.5.17.ebuild,v 1.1 2009/05/11 13:00:54 hanno Exp $
+
+inherit distutils
+
+DESCRIPTION="duplicity is a secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="s3"
+
+DEPEND=">=dev-lang/python-2.3
+ >=net-libs/librsync-0.9.6
+ >=net-ftp/ncftp-3.1.9
+ app-crypt/gnupg"
+RDEPEND="${DEPEND}
+ >=dev-python/py-gnupg-0.3.2
+ >=dev-python/pexpect-2.1
+ s3? ( dev-python/boto )"
+
+src_install() {
+ distutils_src_install
+ rm "${D}"/usr/share/doc/${P}/COPYING
+}